Mazda MX-6 Forum banner

21 - 40 of 1769 Posts

·
Registered
Joined
·
1,244 Posts
Discussion Starter #21 (Edited)
i found different links for tie rods....

http://www.ebay.com/itm/2-Front-Inner-Tie-Rod-Ends-Steering-Part-EV295-/300489335596?pt=Motors_Car_Truck_Parts_Accessories&fits=Year:1994|Model:MX-6&hash=item45f68f632c&vxp=mtr

^inner tie rods

http://www.ebay.com/itm/2-OUTER-TIE-ROD-ENDS-PROBE-626-MPV-MX-6-PROTEGE-ES3197-/321024838168?pt=Motors_Car_Truck_Parts_Accessories&fits=Model:MX-6|Year:1994&hash=item4abe924a18&vxp=mtr#vi-ilComp

outer^^

New Control Arm Kit Front Lower Ford Probe Mazda 626 MX 6 93 94 95 96 97 | eBay

^^control arms

93 02 Ford Probe Mazda MX6 626 1 8L 2 5L V6 DOHC KL Valve Cover Gakset Set | eBay

^^valve cover gaskets

im looking at a little over 120 for everything.

are those parts what im looking for? also, im debating on getting the inners. should i even worry about replacing the inners, and just focus on replacing the outers? or just get everything? lol. how can i inspect the inner/outer ends to verify they need replaced? im just trying to save money if i can.
 

·
Registered
Joined
·
651 Posts
If the inners boot is separated or the joint makes noise when you move it or has any play at all, then it should be replaced. The outer tie rod is Linda the same, if it has a bunch of play in it or the little greese pocket type boot on it is split or broken then replace it too.
 

·
Registered
Joined
·
651 Posts
Everything looks like its what you need, but I would be careful on the control arms and inspect them before installation. Mine had little cracks in the welds and they were brand new. So just be careful
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #24 (Edited)
Update on the ticking.

DSCN0914_zpsa0881600.mp4 video by brotheronk | Photobucket

it was recorded on a different camera. so the quality isnt as good. and it was night time and the camera dont have a light. but regardless you can definitely tell a difference in the sound. the tick is still there. but is alot softer, and comes and goes. i drove around with the seafoam in it about 30ish? miles today. i think ill drive it around another day or so. then change the oil.

also, i started it earlier when the engine was cold (after driving around with the seafoam). the tick was loud like earlier for a about 2 seconds, then quieted down to what it is in the video. put a smile on my face. lol
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #25
If the inners boot is separated or the joint makes noise when you move it or has any play at all, then it should be replaced. The outer tie rod is Linda the same, if it has a bunch of play in it or the little greese pocket type boot on it is split or broken then replace it too.
thanks for the info.

tomorrow when i got some daylight, and it not being 1am lol, ill get it up on jack stands and take a gander.

another question, when i turn the wheel about a turn right or left when im stopped, ill hear a loud popping sound. it doesnt always happen though. when i had the exhaust fixed i asked them to take a look at my suspension. thats when i noticed the bushings on my control arms are shot, which is why im buying new ones. the guy had also told me that my front coil springs were cut towards the bottom and thats where im hearing my popping sound. then on another post i read on this site, it said that the bushings on the control arms was the cause in his case, from where the play in the arms will snap back after the wheel is turned so much one way.
 

·
Registered
Joined
·
651 Posts
Could be control arm bushing, maybe the thrust bearing on the strut mounts is bad too. That will surely do it. I say freshen up the control arms, tie rods, and then check your springs. But after that you still get a popping noise when you turn or go over a bump then its probably the thrust bearing. Oh and I'm glad to see another mx6 that is gold like mine :)))
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #27
Could be control arm bushing, maybe the thrust bearing on the strut mounts is bad too. That will surely do it. I say freshen up the control arms, tie rods, and then check your springs. But after that you still get a popping noise when you turn or go over a bump then its probably the thrust bearing. Oh and I'm glad to see another mx6 that is gold like mine :)))
i checked the tie rods earlier today. the boots seem "clean" and intact and there is no play. they seem okay. so i ordered the control arms and valve cover gaskets.

and yeah, i rarely see mx6s anymore, and when i do it surely isnt gold. the last one i recall other than mine around my area was a black primed one. you dont rarely see a gold/champaign color car anymore. let alone a gold mx6 lol.
 

·
Registered
Joined
·
651 Posts
To me I think they look the best, the sky blue ones do too. My other favorite. Check mine out bud, you might get some ideas on what you want yours to look like haha
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #29
also, completely off topic. the guy i got this car from gave me these rims to go with it. they are gear r finalspeed 17 inch rims. i was curious if they would fit the car. or if they would rub. i havent had them on the car yet because the tires on them are bad.



the specs on them are

rim size is 17x7
offset 43
and i think bolt pattern is either 5x100 or 5x114.3
 

·
Registered
Joined
·
651 Posts
If they are 5 x 114 then they will bolt up. But it depends on the tire width? If they are wider than 205 then I think they will rub on the stock struts
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #33
another question. about my trans, when i take off in first, you can hear a slight whining noise that progressively gets to a higher pitch the faster i move. it almost sounds like a faint dog box trans. is this normal?
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #35
Its a five speed right? It might be a be a throw out bearing?
Yeah its a 5 speed. And idk, it almost sounds like gears humming at a high pitch. Also if I shift any higher than 2500rpm from 3rd to 4th, it will grind. 1st as well. I have to be basically stopped to put it back into 1st.
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #39
Good god bruddah. Time to get a new tranny!
maaaaaannnnnn, just more stuff to replace lol. i mean, it seems as if the trans is fine, just grinds in 4th at a mid-high rpm range. and 1st unless im practically stopped. i dont even shift into 4th anymore anyways, 4th gear is over so fast during normal driving, so i just go from 3rd to 5th.
 

·
Registered
Joined
·
651 Posts
Maybe you could replace synchros instead? Idk how but I'm sure someone could walk you through it. I know how you feel, these cars get trashed and people like us have to fix the mistakes
 
21 - 40 of 1769 Posts
Top