Mazda MX-6 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
I've been working on a 2gen GT that i bought this summer and i still can't get the [email protected]#%ing thing started. I bought the damn thing for about $800 dollars with a busted atx so i replaced that with a mtx i also bought some headers for it cuz the stock ones were rusted. I have spent about $1500 for this piece of **** and still this mofo won't start. I had this guy look at it and he told me i wasn't getting no spark at the plugs so he said he is 90% sure that the freaking distributor is ****ed up. I go look for a price on a disty and these freaking things go for $250-$300 . I finally get a deal on one from a friend for a little over 2bills so i'm just waiting on that disty to get here sometime this week but at the same time he had a used disty at his house and he wasn't sure if it worked so i took it home and put it in my car and i still nothing happen so i really hope the used disty is f#@ked. i bought the car for so cheap cuz it had no reverse on a atx. it turned on like a charm for a while then it started stalling on me and then it stopped then i did the mtx swap and now the mofo will start but only for like half a second and then stall.


i got the new freaking disty on the freaking pos probe and the bitch still doesn't start not even for the half second that it used to and to top it off while i was working on it i put some weight on the engine bay and the front passenger spring just came off the mofo strut or it broke.


please help
 

·
Registered
Joined
·
198 Posts
you might need new plugs and wires......... Buying things that are cheaper usually have more probs...
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #3 ·
italianjs said:
you might need new plugs and wires......... Buying things that are cheaper usually have more probs...


everything is new including the disty
 

·
Premium Member
Joined
·
1,553 Posts
I thought you said the distributor was used? I had to do the Distributor and plugs and wires and it was not cheap at all. Hell nothing is on these cars. But it solved my issues...
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #5 ·
i tried a used one and got nothing then i bought a new one and still i get nothing.
 
1 - 5 of 5 Posts
Top