Mazda MX-6 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Just got done doing a gt to lx swap but left the lx ac system right in the car thinking it would function as long as I can charge it up and turn it on. Apparently not the case. I don't know if there are any differences between the gt ac system and the lx ecat ac system. I've scoured the forums for a lead but I'm not getting anything definitive. Please help.... I've got 12v on the 2 green and white wires coming into the ac relay. Also 12v at the solid green pressure switch wire. If I ground the green wire, I get a complete circuit, ac relay clicks and clutch engages. If I jump the connector, I get nothing. When ac switch is on and blower lever is on, the main rad fan turns on, but not the condenser fan. If I jump the switch at the reciever, the condenser fan will turn on. Ive done the retrofit and added about 2 12oz cans of refrigerant, an anout 2-3oz of oil. Not accurately measured, I know, but I should get something. If the compressor is supplied direct voltage, it will turn on and vents will blow cold. Just won't turn on from inside the car. I've swapped the front harness, main harness, dash harness and ecu to run the f2t and mtx. Anybody have any ideas on what I'm missing or didn't do right? I'll be surprised if I get a reply back, but any input is super appreciated.
 

·
Registered
Joined
·
251 Posts
It is controlled by the ECU, so check that the pins in the ECU connector are the same. The ECU gets the signals from the AC cabin controls, such as AC is switched on, blower fan is on, the AC has sufficient pressure and switches the AC compressor relay to ground. Also does idle up to compensate.
 
  • Like
Reactions: MXican-6

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
It is controlled by the ECU, so check that the pins in the ECU connector are the same. The ECU gets the signals from the AC cabin controls, such as AC is switched on, blower fan is on, the AC has sufficient pressure and switches the AC compressor relay to ground. Also does idle up to compensate.
I checked the black and blue wire coming out of the pressure switch on top of the dryer and it's going into the correct pin location in the ecu. I also have continuity from the ecu to the switch. Something is telling then ecu not to send ground to that switch to turn on the compressor. I know something is happening, the main cooling fan comes on with the ac switch and that's it... I also went from logic climate control to non logic climate control and just left the hvac unit right in the car. According to the wsm diagram, the ac switch should still signal out to turn the compressor on. What am I missing? I had the dash out of the car to swap the dash harness... I'm wondering if I remembered to plug in the temp switch at the evaporator core. Any input is appreciated. Thank you fellow mazda owners.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
SOLVED

Green 5 pin connector behind the glove box wasn't plugged in... don't rush your projects folks. Thank you everyone for your input.
 
1 - 6 of 6 Posts
Top