Mazda MX-6 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter · #1 ·
First off, basic details and history of car.

92 mx3 gs
ran perfect before swapping motors
bone stock minus HEI mod, and CAI
no CELs prior to swap
5speed car


We sold my millenia 2.5L to my buddy with above car, motor ran great prior to pulling it out of my escort.I sold him my KL07 ecu and KL02 vaf along with my 93 pgt disty.We installed the motor without any problems.He decided to keep using his disty(supposedly out of a 93 pgt) because it was modded for his HEI/external coil.At this point, here is what we have:

Motor cranks great
Motor is getting fuel(pulled plugs and they are soaked)
motor is getting spark(checked at all front three plug wires)
disty is getting spark from coil(checked at power tower)
timing was checked 3 times, its dead nuts
all sensors were double checked to be plugged in
rechecked fuel lines to make sure they arent reversed
tried 2 different fpr's,both off running cars
tried stock k8 ecu, kl07 ecu,and kl48 ecu
tried stock k8, kl02, and je50 vaf's
tried to start car in diagnostic mode
jumped fuel pump through diag port to check it was working
added two more 8 awg grounds one on timing side, one on trans
sanded down all three harness grounds to make sure of good contact
triple checked firing order(tried firing order from cap, and also from repair manual)
modded another disty from running car and swapped in
double checked all HEI wiring
double checked all engine bay fuses

Basically the car will crank all day long, but wont start or even hiccup like it should if it were trying to fire.Weve been swapping parts for the last couple days with no progress.From my standpoint, we have both spark and fuel and the timing looks to be spot on.One wierd thing i noticed is that if we use the stock k8 ecu, and jump the diag port, the fan will stay on.If we use the kl07 or kl48 ecu, the fan will cut on for about 1/2 second then shut off.It almost sounds like a relay is cutting out.Im completely stumped, and have never replaced so many parts without some sort of progress.Please offer up anything i can check, he lives over an hour away and i want to have an arsenal of things that i might have forgotten about to try out.Thanks in advance.Sorry for the long post, more info the better right :p
 

·
Registered
Joined
·
380 Posts
Bit confusing, your friend has a 1993 MX3 and you are swapping a 2.5L KLDE/KLZE into it that was in an escort, right?

It could be a OBDI VS OBDII type thing. You are talking about some ECU's that I have never heard of. Most common ECU I have heard of are KL36 and KL31. There is also a KL62 that I have seen before from an OBDII car with KLZE.

Figure out these things -

Is the car OBDII or OBDI. Distributor is different as far as I have read. Are there 3 plugs coming out of the ECU or 4?

Things to do:

Make sure you are using the correct wiring loom. If it's OBDI, use an OBDI ECU and disti. If it's OBDII, use an OBDII wiring loom, disti, and ECU.

Common setup is - OBDI - KL31/36 ECU - OBDI Disti - JE50 VAF. 1993 would almost 100% be a OBDI disti.

Yet you talk of a KL07 ECU and KL02 VAF - sounds like OBDII to me!

Check that stuff out. Also, I'd forget about HEI mods, if you have accidentally mixed up OBDI and OBDII stuff, you're complicating it more by making a HEI mod on top.
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #3 ·
Bit confusing, your friend has a 1993 MX3 and you are swapping a 2.5L KLDE/KLZE into it that was in an escort, right?

It could be a OBDI VS OBDII type thing. You are talking about some ECU's that I have never heard of. Most common ECU I have heard of are KL36 and KL31. There is also a KL62 that I have seen before from an OBDII car with KLZE.

Figure out these things -

Is the car OBDII or OBDI. Distributor is different as far as I have read. Are there 3 plugs coming out of the ECU or 4?

Things to do:

Make sure you are using the correct wiring loom. If it's OBDI, use an OBDI ECU and disti. If it's OBDII, use an OBDII wiring loom, disti, and ECU.

Common setup is - OBDI - KL31/36 ECU - OBDI Disti - JE50 VAF. 1993 would almost 100% be a OBDI disti.

Yet you talk of a KL07 ECU and KL02 VAF - sounds like OBDII to me!

Check that stuff out. Also, I'd forget about HEI mods, if you have accidentally mixed up OBDI and OBDII stuff, you're complicating it more by making a HEI mod on top.
i dont mess with obd2 stuff.Every part listed is from an obd1 5spd car.Im reading the large numbers right off the parts as i pull them from the donor cars.Ive done this swap in 4 escorts so far, i know how the wiring matches up.He is using the same exact harness, ecu, and vaf i was using to run this motor in my escort.There should be no issues with plug and play with this swap.Its something else underlying that im missing.Car has spark, fuel, and timing is perfect.Ive now tried to replace cps sensor with two other known good parts, as well as swapping vaf's since my original post.Car still cranks as though it has no compression.Motor was in great shape when pulled, cant loose compression being transported from one car to another.
 

·
Registered
Joined
·
43 Posts
When i rebuilt my last 93 pgt motor i had same problom my timing was out by 1 rotation but still fired like it was right in time but after fixing it car would smoke three gears of rubber down road then locked up week later L.O.L. well wish you best luck with your wip
 
1 - 4 of 4 Posts
Top