Mazda MX-6 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
140 Posts
Discussion Starter · #1 ·
Here's the deal. My car sounds like shit right now. I hear a noise coming from under my hood. It sounds like the pistons? It's real loud. Almost a clicking, and it get's louder and faster with more gas. Is this an exhaust leak? Also when I'm at idle after my engine warms up I can hear a whistleing. And when I put the clutch in, the whistleing stops. Any help will be greatly appreciated!
 

·
Registered
Joined
·
711 Posts
The whistling noise is your release bearing for your clutch. The other noise is probably your lifters. Checked your oil level lately? If it's OK, then you probably need new lifters. I think they are about 6-7$ each. You've got 12.
 

·
Premium Member
Joined
·
3,962 Posts
The lifters on our cars are notorious for clogging up and ticking. However, in most cases, replacement is not requrired. All you need to do is buy a quart of Marvel Mystery Oil. Drain a quart out of your system, put the quart of MMO in, and run it for 500 or so miles. That usually gets rid of it. The lifters themselves are only available at Mazda dealers (at least thats the only place I've been able to find them) and run about $30 each. Also, lots of times it's nothig wrong with the lifters themselves, but the oil passage in the rocker arm gets clogged. Give it a try and let us know what happens.
 

·
Registered
Joined
·
666 Posts
$30? You're getting raped.
No offense.
At my local mazda dealer they're about $24 apiece, still high. At the shop where I got my engine rebuilt they're $15. So you can get them cheaper.
Also, marvel mystery oil works, but, I had better luck with Rislone. It's good stuff, about $3.99 a quart at AutoZone, Western Auto, Advance Auto... Dunno if those are all over the country or just in my region, but, any autoparts store should have it.
Also, if it isn't your lifters, it could be a broken stud on the exhaust manifold, causing an exhaust leak. If you pull the heat shield off and see soot anywhere, you probably have a broken stud. I had that happen, sounded like a go-kart engine until I got it fixed.
 

·
Registered
Joined
·
140 Posts
Discussion Starter · #6 ·
How did you get the stud repaired? Was it lotsa money?
 

·
Registered
Joined
·
44 Posts
I think its probably a exhaust leak because mine did the same thing pull off the exhaust shroud and make sure the bolts are not loose holding on the manafold
 

·
Registered
Joined
·
140 Posts
Discussion Starter · #9 ·
I appreciate everyone's help in this matter. I get paid on Monday, so I will try the mystery oil. I have made sure the top bolts on the exhaust manafold are tight, but I haven't checked the two underneath. I'll go do this stuff and I'll let everyone know what happens.
 
1 - 9 of 9 Posts
Top