Mazda MX-6 Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
639 Posts
Discussion Starter · #1 ·
ok well heres how it went, my car is running perfectly beutiful like always and today was the day i decided to return my car to stock again

Puled my guages,replaced MBC with the stock selonoid,replaced stock ecu,replaced HKS intercooler piping w/stock stuff,switched conical with stock box.pulled turbo timer, all radio back to stock stuff, and pulled my walbro 190 and put back the stock pump. i think that covers it so the only thing left on the car in the exhaust.

So i start the car and it seems to run fine so i run inside for a minute to grab somthing come back out still fine but one i jumped in and touched the gas to move i got a puff of smoke,and another and another everytime i touch the gas, but it idles clean.

I checked the vaf thinking i didnt replace the plug but i did. im not sure what in my list of stuff i could have messed up or hooked up wrong to cause it to smoke. motor still idles fine, but smokes when u hit the gas, my only guess could be something with tthe fuel pump,ecu,or the stock boost selonoid, if anyones got a clue whats goin on here, please lemme know i guess for now i gotto put selling the car on hold till i fix this stupid shit.
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #3 ·
nope ive been driving easy is there anything that i could of hooked up wrong/backwords or anything that the ecu or seloniod does that i could have screwed up that could cause it or somthting with the way i put the fuel pump in. i need somethin to go on
 

·
Banned
Joined
·
27,927 Posts
Does it smoke at ALL at idle? Maybe let it sit idling for awhile and see if there is anything that might be inside burning off causing it to smoke (oil in the intercooler pipes?) unless you can visually see that it is coming from the tailpipe?

Take it for a drive and see if you can see WHEN it does it. If it doesn't do it below 3,000 rpm but suddenly starts when you come to a stop, if it doesn't do it cruising at less than 3,000 but suddenly starts when you go above 3k, you can almost gaurantee yourself that it is the turbines oil seal on the exhaust side.

http://www.mx6.com/forums/showthread.php?t=137090 - I have to re-link my cardomain pictures in the beginning.
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #5 ·
not that i can see it seems like its running normally,i can see it coming ight outta the muffler in back[and in a small exhaust leak underneath]ill take it for a drive and see what happens, also i was reving it up in nuetral to about 1500-2000rpm and thats when it would smoke and id let off and go inspecting also the smoke is not blue and its not white its like a greyish if it makes a diffrence
 

·
Premium Member
Joined
·
1,535 Posts
I like the "great running" car in your Sig :D

Good luck with your smoke issue

Peace
NSXR
 

·
Banned
Joined
·
27,927 Posts
When you're doing your test driving, make sure you check your oil level before you go as well as after. Not that all of your oil will leak out in a short drive, but if the seal is already gone and you keep driving it, it'll only get worse. Again, this may not be your problem but it is a very likely candidate. If it doesn't smoke much at idle but smokes at or around 3K and up...........

Take it for a drive and see if it does anything that I said.
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #9 ·
im gonna gonna go outside now and reset the ecu and take it for a short drive i am praying it has to do with the ecu or something just buring off ill let you guys know what happens in like 40 mins
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #10 ·
ok i reset the ecu and nothing, still smoking, reved it up to around 1700 rpms and it made a big grey puff then disapeared as rpms dropped, im also getting some smoke under the hood coming up from the engine bay but that might be because of an under the car exhaust leak just comin up from the underbody. i was gonna drive it but its dark and i wouldnt see much anyway also im to paranoid that i just did somthin stupid and by driving it i am potentially gonna f-sumthin up worse and maybe cause a real problem. tomaro im gonna put back on stock exhaust, and put back in my zombied ecu along with my other fuel pump,also check those plugs that the turbo timer taps into,i dunno if they would have anything to do with it but im gonna go over everything i did today. if i dont find anything tomaro ill leave it upto the mechanic to figure out for me.i just wanna get it fixed soi can sell this bitch and get my new car so i can stop have stuid old car problems. uhggggg a once only classic car lover is now loosing his love for old stuff
 

·
Registered
Joined
·
447 Posts
pull your intercooler piping off and see if its coated with oil. if it is, you can be pretty sure that the turbine oil seals have eaten it.
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #12 ·
i dunno if i would see anything i had just installed the intercooler piping and there was already that small amount of oil from the pcv system in there. but ill look
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #13 ·
ok well everyone thanks especially sick for the helpful replys on stuff to check but the car is A OK now i dunno im guessing it was just somethin in the intercooler pipes burning off like sick said cause i started it again this morning and it smoked a little tiny bit a ton less than yesterday and last night. so i decided to take it for a drive it smoked a little up my street very little, took around a couple back roads and no smoke stopped reved it a couple times and i got 1 little light poof so then i took it out for about another 15 mins and took it on the highway after cruiseig about 10 mins on the highway and everyhting runnning excellenetly took it home stoped and had the gf rev it and had perfectly clean clear non smelly wonderful exhaust. im very happy to say the turbo and everything else is ok and the cars back up for sale with my same description as a great running car. sorry for the rant im just glad its ok now

PS: god its slow without all my shit in it lol
 
1 - 13 of 13 Posts
Top