Mazda MX-6 Forum banner

1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
I have now changed the starter and still my MX6 93 starts when it feels like. Like a firecracker he starts; oh but tomorrow who is to tell. I tried retrieving the malfunction codes but nothing happens - the check engine light stays on forever; no flashes, no going away. Can anyone please tell me what can be causing this behavior. Distributor cap has been changed, spark plugs, wires, OX sensors. What else can I do? Yes, one more thing. Is the fan supposed to start when the car is still cold? That is my only lead when he does not start. Other than that - I cannot find anything else. Thank you. I am going broke with this car - but at least I know what has been done to it or do I?
 

·
Registered
Joined
·
123 Posts
Ignighter

Get a new ignighter.. Not a used one a new one from the dealer.
 

·
Registered
Joined
·
3,167 Posts
Jerito said:
I have now changed the starter and still my MX6 93 starts when it feels like. Like a firecracker he starts; oh but tomorrow who is to tell. I tried retrieving the malfunction codes but nothing happens - the check engine light stays on forever; no flashes, no going away. Can anyone please tell me what can be causing this behavior. Distributor cap has been changed, spark plugs, wires, OX sensors. What else can I do? Yes, one more thing. Is the fan supposed to start when the car is still cold? That is my only lead when he does not start. Other than that - I cannot find anything else. Thank you. I am going broke with this car - but at least I know what has been done to it or do I?
Niether your post nor your profile indicates what the car is. Is it a 93 V6 or 4-cyl?

What are the symptoms? You replaced the starter...was it not cranking? Or was the engine cranking but not firing? If it was the latter, why was the starter changed?

Are you saying that when you turn the ignition on, the fan comes on but the engine won't start? If it's the V6 model and you've tried reading the codes correctly (grounding the TEN pin etc) but the CEL stays on all the time anyway, then you may have a faulty/flakey PCM. That might explain no spark, erratic fan operation, incorrect check-engine light behavior etc. PCM failures are pretty rare (might want to eyeball the wiring and fuse panels closely before considering tackling the PCM) but they can happen.
 
G

·
Discussion Starter · #4 ·
Mike, my car is a V6 MX6 1993. The starter was changed just to rule it out apparently. I never have problems starting the car when it does start. Yes, when it does not start the symptoms are: fan comes on, it cranks but it will not come on. By the way, about reading the codes, the manual says the car has to be in neutral - is this true? If it is then that would explain why I couldn't read the codes. When the car does start he runs fine. It's just an on and off thing with this car. Any more leads...I will check the wiring but forgive me if I should ask "the wiring running from where to where? Do you mean every wire under the hood? Thanks.
 
1 - 4 of 4 Posts
Top