Mazda MX-6 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter · #1 ·
I have a 93 mx6 w/2.5 V6, I had stopped car but when started back up, it feels like it's running on 3 or 4 cylinders,what could it be?It happened all of a sudden,turn off car after driving perfect,but when started up it starts strange and feels like only 3 or 4 cylinders working, can anyone help, it is only car I have that was running could it be an ECU, or pcm, I just do not have a clue.Any help will be greatly appreciated. thanks
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #2 ·
I have a 93 mx6 w/2.5 V6, I had stopped car but when started back up, it feels like it's running on 3 or 4 cylinders,what could it be?It happened all of a sudden,turn off car after driving perfect,but when started up it starts strange and feels like only 3 or 4 cylinders working, can anyone help, it is only car I have that was running could it be an ECU, or pcm, I just do not have a clue.Any help will be greatly appreciated. thanks
Well it died, so I replaced the pcm, under the radio inside of car, and the complete distributor, and it still will not start or have spark to plugs, am replacing crankshaft sensor next as I have been asking tons of questions but no answers, and repair books are great on showing or telling you things about repairing your car, but if you don't understand what they are saying it does you no good.Example, trying to check if power is getting to distributor, well they explained it so difficult, it took my brother 3 minutes, and I checked it myself!Oh well, if this isn't it, then I have a new crankshaft sensor.Can timing being off act same way, like a timing belt skipping time? Would it keep car from getting spark to plugs? I keep asking question but not getting much answers on the internet, I don't have the time or money to tow to a shop and have someone who doesn't know the car do same thing as me! Thanks Dave H.
 

·
Registered
Joined
·
12 Posts
Well I replaced the PCM, the crankshaft sensor, the timing belt, water pump , belt tensioner, distributor, new belts and hoses, it runs like new again, as it is a 1993 MX6 LS w/ 2.5 litre V6 with 117k on the clock, has beautiful beige leather interior with no tears, and I will be painting it come spring, as I had a body shop and car lot( used) for 38 yrs, I will post those pics for it when it is done , but will be posting the pics for my 1996 MX6 w/ 2.5 litre V6 which I am painting red, both of them are white! I have 2 MX6'S.
 
1 - 3 of 3 Posts
Top