Mazda MX-6 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1,190 Posts
Discussion Starter · #1 ·
I just replaced the fuelfilter because my other one went bad...I let my car run for about 10 minutes and has a very loud pinging. When it is in park or nuetral, it will rev it self up to 2500rpm's and then drop to 1000rpm's...then it keeps doing that none stop, this has been going on for awhile though and would like to fix it..any sugestions?
 

·
Registered
Joined
·
158 Posts
The RPM i would looking into the PCV valve maybe get a new one Only like 5$ but about the pinging I have no idea for that :(
 

·
Registered
Joined
·
1,190 Posts
Discussion Starter · #3 ·
I will look into the pcv valve for the revving...about the pinging...im screwed..and need help. I can't drive it..im affraid it will blow the head...
 

·
Registered
Joined
·
449 Posts
do you have a GT? or N/A engine?

What grade gas did you get? Premium? If you have a GT, and you used regular fuel, your knock sensor may have gone bad, which would cause the pinging.

Geez, i've never heard of an engine acting that eratically before!
 

·
Registered
Joined
·
158 Posts
The Head? y0 have u looked into your timing belt?
Maybe its off when u say pining do u mean like nocking or like hitting sound and does your car shake?
 

·
Registered
Joined
·
1,190 Posts
Discussion Starter · #6 ·
it doesnt really shake...nothing thats not normal, just that loud slapping (pinging) sound from under the valve cover. i am pretty sure that its my valves but I am not sure how to fix it...
 
1 - 6 of 6 Posts
Top