Mazda MX-6 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2,942 Posts
Discussion Starter · #1 ·
Hello, thank you for reading my post, I really need help on this one. I have read a lot on the ATX tranny problems but haven't seen this one, here it goes...

I go park and when I take my foot of the gas I start backing up, I'm like 'what the f...?' so I look and the stick is in park but its showing R on the dash? Then I shift down and it is in R and R but then N is D and D is S etc. however when i go up its the same except R is N. (Hope that makes sense, basically it is the gear below what it should be) Anyways. I start and stop, off and on, i try driving and stopping, nothing works. Then I turn it off and unlock the tranny and place it in each gear and then start it and everything is fine. Yeah!!! right? nope. Today (2 days later) it happens again only this time my old remedy isn't working, so what do you all think?

Some things to note, I haven't had a tune-up in 6 month's, we just hit a cold spell and had 2 feet of snow and slush (could it get in there and then freeze and expand?) I also wiped out really good and drove through a snow bank at high speeds, lastly (my poor car!) I bottomed out going 30KM/h in a HUGE, UNMARKED construction pot-hole thingy!!!!!!! Mind'u that last thing happened 10 days ago.

Please help me all you MX6 guru's,
Cya all,
Claeren.
 

·
Registered
Joined
·
734 Posts
Well, I've heard of that before in other cars... and in MOST cases it is just a type of spring that needs to be replaced... Don't know for sure about the MX6's because the only thing I ever did to one is change the MAF sensor...
 

·
Registered
Joined
·
734 Posts
pretty dern sure it is a spring though... almost sure enough to bet on it...
 

·
Registered
Joined
·
2,942 Posts
Discussion Starter · #4 ·
Thanks...

I was talking to a Mazda tech. friend and he said it's probably the linkage assembley too. Anyone know how much that costs? Is it a lot of labour? Any other ideas?
Thanks again,
Claeren.
 

·
Registered
Joined
·
475 Posts
Sorry Dude

Hey Claeron, sorry for coming off as bratty/pissy in my post in the lounge. I really didn't mean it to comeout like that but now that I read it over I agree. And are you indirectly calling me a post whore??? I mean I like to post but there are plenty of "others" who are worse than I am.

As for your tranny, lucky for you it doesn't sound like its an actual transmission problem. It sounds like there is something the matter with the spring that connects the transmission linkage to the gear shift. If it was your tranny you'd be lookin at big bucks but I suspect it'd be more like 200-300 (us) bucks. That is just a guess though. It may be alot more or alot less.
 

·
Banned
Joined
·
55 Posts
i hope it's just a shifter cable problem other than a serious tranny works. sometimes the engine wouldn't start because it isn't in P even if it says P. i'd check the shifter cable first.
 

·
Registered
Joined
·
2,942 Posts
Discussion Starter · #7 ·
hello...

no hurt feelings hey allworld, I was just a little pissy thats all, sorry. (Your not a post whore =))

Anyways, when you say that its like 300$ that's mostly labour hey? How much do you think the part is? Probably a lot less then that eh?

Boston, I'm not quite sure what your saying but I can't get it into P at all, I've been starting it in N, mind you it seems to have fixed itself again (for the moment).

Thanks again all,
Any other suggestions are welcome.
Cya.
Claeren.
 

·
Registered
Joined
·
734 Posts
If you can find a mx6 maintenance book out there and locate the part.. I'd be pretty sure you could do it yourself.. and as for the spring.. junkyard.. or buying a BRAND NEW one shouldn't cost very much at all
 

·
Registered
Joined
·
2,942 Posts
Discussion Starter · #9 ·
Question?

How do you guys get under you cars? Cheapest way?
Silly question I suppose but maybe somebody has an easy way?
Cya,
Claeren
 
1 - 9 of 9 Posts
Top