Mazda MX-6 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
Hey I have a 1992 MX-6 and I just put in a Pioneer CD Player instead of the factory tape deck. I could get the stations fine when I first had the factory radio in there, but when I switched then, now the antenna doesn't go up and I can't listen to the radio. I'm pretty sure everything's hooked up right, the Power Antenna seems to be in right but it's just not working. Does anyone know how I could fix it?
 

·
Registered
Joined
·
488 Posts
Welcome to Mazda power antenna wiring. You need to put a realy on teh power antenna output wire from your radio to switch the polarity of teh signal from positive to negative. Mazda antennas require a negative turn on signal to operate unlike every other antenna on teh market which is positive. Go get yourself a SPDT relay hook terminals 85 and 30 to ground, 86 to the blue power antenna wire coming from your radio and ternimal 87 to the power antenna wire in the car. Now your antenna will work properly.:)
 

·
Registered
Joined
·
2,143 Posts
nice thread....

i did not know about this. im glad someone posted about it. im going to be installing my Pioneer Premier 720 (great hu) in my 6 from my cherokee soon.

SolarSlash
 

·
Registered
Joined
·
2,143 Posts
damn you greg...

i went and bought the relay without even checking if i needed it. tried to get it to work for an hour. come to find out i didnt even need the relay!! doh!! hehe, jk greg.

SolarSlash
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #5 ·
How??

So what did you do to make your antenna work. I still cant get radio stations on mine. Just wondering what you did to make it work now?? Thanx.
 

·
Registered
Joined
·
2,143 Posts
uhh..

hmmm...maybe its something to do with the cd player. because my roommate has a 1st gen and the only aftermarket players he's used are Pioneer and he's never had a problem with the antenna. i got the '94 and a Pioneer deck soo...i dont know. hehe. does your deck have a lead called the System Control wire? usually blue id imagine. connect it to the power antenna wire and see if that works.

SolarSlash
 

·
Registered
Joined
·
488 Posts
Re: damn you greg...

SolarSlash said:
i went and bought the relay without even checking if i needed it. tried to get it to work for an hour. come to find out i didnt even need the relay!! doh!! hehe, jk greg.

SolarSlash
Silly boy, I didn't say you needed it for the 93 and up.:) The second gen hassome Ford wiring designs in them, specificaloy the radio system, it's why we have 5X7s, the Ford only speaker size.:)
 

·
Registered
Joined
·
2,143 Posts
hehe

ya, i shouldve checked more closely eh? im silly :)

as for ur antenna AK92MX6, my roomy doesnt have the power antenna. sorry. good luck on getting it to work.

SolarSlash
 
1 - 8 of 8 Posts
Top