Mazda MX-6 Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
9,653 Posts
Discussion Starter · #1 · (Edited)
So I got the 6 running again today. drove it around for a couple hrs, when I got back I noticed I kept getting shocked whenever I touched the car.. pop the hood and I can visually see the power plug on the power tower arcing..(not consistant, but its arcing) But I dont know what against? Everything is brand new.. could it be something Inside the disty?. Its like arcing agains the plastic disty cap and rubber boot..
Perhaps its the disty shield? yet nothings touching

 

·
Premium Member
Joined
·
10,652 Posts
I'd bet it's the shield... if it is, and you want to keep it, run a grounding wire from it to a good ground point...

also make sure there aren't hairline cracks in the rubber on the boot that crosses through the shield.
 

·
Registered
Joined
·
778 Posts
grounding the shield wont help anything (if anything it will allow it to jump to the shield easier), remove the shield!
 

·
Premium Member
Joined
·
3,955 Posts
Then remove the disty ;)
 

·
Registered
Joined
·
3,686 Posts
you can buy 626 coilpacks for like 40 bucks.. giving up on the six darren?
 

·
Registered
Joined
·
9,653 Posts
Discussion Starter · #9 ·
nah its just not a priority right now, Child support will be hitting me pretty hard soon, so im savin as much as I can so I can afford my bills.

I also dont want the hassle of messing with a new ignition, everything setup right now works great, except for that arcing.. it cuts the motor in and out when im trying to put it to the floor
 

·
Premium Member
Joined
·
11,480 Posts
Coilpacks are pretty cheap, Im thinking its the hassel of modifying the crank pulley and MS to set up for a trigger that is external to the distributor.

I will be making this mod to my crank pulley here after I get home from my trip. I can always help you get it sorted out if you dont wanna mess with the disty.
 

·
Premium Member
Joined
·
5,189 Posts
Im thinking maybe I should make the hole larger and go from there.
That sounds good, and put some electrical tape around the boot also (maybe the liquid type) because the boot is compromised...unless you want to buy a new wire.
 

·
Registered
Joined
·
9,653 Posts
Discussion Starter · #13 ·
well cutting the sheild didnt help.

im actually quite pissed right now, drove to my dads, about 1 mile away, went to drive home bout an hr later, and it doesnt want to start. It starts, runs and momentarily dies. It keeps doing this. Finally I get it running and keep it peged at 3k, thinking maybe it needs to be warmed up, but as soon as I let the throttle idle, it kills.. and now just wont start at all. Ended up towing it home.

I definetly got fuel psi, I got spark but it seems very weak. Timing hasnet jumped. Im still getting shocked when I ever touch the car.. any time I crank if over, and then touch the engine later I get a big static shock. Also right before all this I noticed the RPMS jumping up and down, fluttering.. acting weird when I was driving...
 

·
Registered
Joined
·
100 Posts
Hi King6,

My .02 would be to eliminate the ground connection on your distributor shield. This may be difficult since the bolts ground it. If you remove the HEI mod, that would also eliminate the problem. Switching to a new HEI will most likely make the problem worse. Lastly, you could try insulating the HEI connector more, but this still may not be enough.

Reuben
 
1 - 17 of 17 Posts
Top