Mazda MX-6 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter · #1 ·
Ok.. i recently installed the J-Spec cam from Cork Sport.. into my 95 Mazda MX-6 4 banger.. its the intake cam and I noticed a kinda glub glub at idle..... I don't know if I am supposed to do anything to the computer or anything at all to anything.. all I did was take the factory intake cam out.. and install the new J-Spec cam... the car runs good and I haven't had any problems with it.. I just would like it to run smoother at idle... and I have noticed a litle bit of a difference with the new cam.. I have actually had it in for about 2 months now.. but I just don't really like the way it idles rough.. are there any suggestions on maybe getting a chip... or SOMETHING to help make it run smoother.. and if so then please let me know WHAT EXACTLY to get and where.. thanx all..
 
G

·
response

when you change the cams i believe the car is suppose to idle differen't from the original cam, but to get full performance out of your bolt on parts you need to get a chip upgrade. hope this helps
 

·
Registered
Joined
·
148 Posts
Discussion Starter · #3 ·
Thanx.. I kinda figured I needed a chip.. I was debateing on wether or not to get one.. but now I think I am deffiantly going to get it.. any ideas on what to get.. like what chip would help me out most ( brands and part # if possible) and if there is anything else I can do to help it idle smoother..... ohh yeah... and I replaced all the lifters in the engine and I still have a ticking under the hood.. any idea on what that could be.. and (lol) one more question.., as if that weren't enough.. anyone know where I can get a performance exhaust cam to go with the J-spec intake cam???? lol sorry for all the questions in one post.. :confused:
 
1 - 3 of 3 Posts
Top