Mazda MX-6 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hey all. I'm currently in the process of helping A Simple MX6 swap out his interior for black interior (pics to come soon ;) ) We're having a slight bit of trouble with the rear deck lid though. We were removing the rear speakers and noticed all of the screws holding them in were broken about halfway in and are still holding the deck lid in place. Anyone ever have any trouble like this and how did you fix it? We've tried using a extractor but since we've never used one before we probably fucked up trying. Also tried just pulling the piece off since we're replacing it anywayz, tried a hammer, pliers, vice grips, etc. Nothing seems to budge them at all. Any help would be appreciated. Thanx all.
 

·
Registered
Joined
·
1,646 Posts
Alright. Since I don't have a rivet gun or anything I guess I'll be making a stop somewhere tomorrow morning.. Thanks for the help. :tup:
 

·
Premium Member
Joined
·
5,189 Posts
I used nuts and bolts to secure my speakers. Make sure you use loctite on it though or the nuts eventually rattle off.
 

·
Registered
Joined
·
250 Posts
Tip on the easy outs. drill the head of the screw first, set up the easy out and hammer it in so it sticks. you don't have to smash the thing, so don't go super nuts, then use an adjustable wrench instead of the drill to back the screws out.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #7 ·
Well he ended up just getting Best Buy to install rear speakers along with the black deck lid he brought so it all worked out in the end. Thanks for the help everyone. ;)
 
1 - 7 of 7 Posts
Top