Mazda MX-6 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,153 Posts
Discussion Starter · #1 ·
last night on the way home from a run up mount dandy, my stereo turned off along with the clock.. i knew it would be the room fuse.. which also controls the interior lights

so i stopped at the servo and bought a pack of fuses, one after another, they blew soon as they touched the socket.

theres obviously a short somewhere, but i cant find it! it seemed to happened suddenly for no reason at all too.

i was just wondering if this has happened to anybody else and if there were any trouble areas i should look at? im thinking that the light on the roof could be responsible, because it has been playing up lately (only comes on half the time).

cheers guys.
 

·
Registered
Joined
·
454 Posts
Hey Brad,

Check your earthing points in the car and engine bay.

I recently replaced my main fuse and forgot to hook the earth up. I blew the room fuse when I tried clicking the car over.

I used to blow them all the time. I then replaced it over and over, then eventually it just stopped. My stereo used to blow that fuse for some reason. Dunno why. Maybe it was drawing too much power through the circuit or something.

Put a multimeter across the prongs on the fuse plug in the board. if you're gettin I think over 15 amps then you're having a short happening as you said or maybe even a spike.

Best way to check this would be to get a copy of the wiring diagrams and trace all the wires, plugs, globes etc... that link up to that fuse and try and trouble shoot by going through each one.

Regards

Zako
 

·
Registered
Joined
·
1,489 Posts
Which fuse controls the ciggy socket on 2nd Gens? I can't get my phone charger or electric pump to work off the ciggy socket at all...and the ciggy lighter doesn't work either. Everything else works fine....
 

·
Registered
Joined
·
454 Posts
Have you actually had a look at the socket behind the lighter?? Some of em can work their way off sometimes.

I know in the first gen it's the 'room' fuse. Dunno about the 2nd gen, but thought I'd post a suggestion for ya

Regards

Zako
 

·
Registered
Joined
·
1,489 Posts
Cool thanks will check it out :)
 

·
Registered
Joined
·
1,153 Posts
Discussion Starter · #6 ·
thanks john,

it was a bad earth.

thing is though, now my head unit isnt turning on.. this has happened before, and after a couple times of taking the key out the ignition, it turns on again.. not this time. :mad:

my ciggy lighter socket also doesnt work.. one day, the lights for the heater stopped working, and took the ciggy lighter out with it.
 

·
Registered
Joined
·
454 Posts
This is where it gets tricky.

When I installed my cd etc... I hooked up my power source via the "room" circuit, so whenever that fuse blew, my stereo went out too.

What you might need to do is just check the wiring on your head unit. If someone else wired it, they may have put a fuse inline in the wiring, and that may have blown.

I'd suggest getting on your knees, with a torch and going through all the fuses. You'd be surprised at all the little problems this could fix if you replace one or two.

The lights behind your heater console could be blown. The globes are pretty old and frankly, quite a bitch to get to, but can be done. If you can remove it, just check the globe, if not, just make sure the socket is secure. Same with the ciggy lighter. Check that the plug is attached. Mine always managed to get itself loose

Regards

Zako
 
1 - 7 of 7 Posts
Top