Mazda MX-6 Forum banner
1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
Okay talked to Dad some more, it's a 91 ... It smokes at start up, I am going to try the engine flush to see if it will get rid of the engine noise, if it don't we'll go the old fashioned route.

This is a weird one, when you shut it off, you have to have the high beams on, if you don't the battery goes dead?

Also the cruise control shuts off if you turn.


Any ideas?
 

·
Registered
Joined
·
268 Posts
What's the history of this car? Sounds like you've got some strange problems. But as far as the cruise control goes, they have been pretty flaky on these cars and I'm not surprised you have problems with it. Do a search on this board and you might find some answers there. Also, what trim line is it (GT, LX, DX)?
 
G

·
Discussion Starter · #3 ·
Flaky problems

Dad bought it used 2-3 years old, it has 230,000 miles on it. Nothing major has ever been done to the car, Dad was going to drive it "until the wheels fell off", but bankruptcy and the loss of our transportation led us to this car. So rather than tolerate it I'm going to fix it.
 

·
Premium Member
Joined
·
3,962 Posts
Smoke at startup generally means valve seals (assuming it's blue smoke). I believe these can be replaced with the head still on the car. Even if you do have to remove the head, it's actually not terribly difficult especially if it's a non-turbo.

The headlight problem sounds like a sticking relay, and the cruise controls sounds like a bad connection/wire somewhere. That one might be difficult to fix. I highly suggest you pick up a manual for this car, or actually go to www.alldatadiy.com and sign up. It's only $19.99 a year and includes a lot of information the manual has, like wiring diagrams and stuff.
 
1 - 4 of 4 Posts
Top