Mazda MX-6 Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
ok i finally got my car running after it was sitting for a while and i took it for a test drive and then i came home and turned off the car (cars been running rough due to sitting to long) but n e ways i went to start it again and its not turning over its making a click sound but not turning over the lights r dimming when i try to start it as well the console lights are but headlights are not someone help me out
 

·
Registered
Joined
·
1,434 Posts
usually a clicking sound is a sign of a loose battery terminal. Tighten those up
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
battery isnt dead becuz my headlights r very bright and all electrical is working fine ill try tightening the battery cable to see if that works..... i was thinking mayb bad ignition switch? im still lookin for answers so all help is appreciated :)
 

·
Registered
Joined
·
13 Posts
i had a similar problem do u have an alam check that out b cos my alam was clicking wen turned over but in the end it was a dead battery check it out
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
lol i definetly know its not a dead battery becuz i havent charged it or anything and im able to go out there and turn everything thats electrical on and everything is bright headlights and everything (still looking for answers)
 

·
Registered
Joined
·
5,273 Posts
is the car auto or manual ?

if its auto check if it goes in N

if its manual try jump starting it.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
its a manual and ok everyone thinks its a battery but i dont think it is but im also open minded so imma go check to see if i can jump start it
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9
ok i hooked up my jump starter and tried to start it and the same thing happened...... so its not the battery, battery is fine (still looking for answers) :( thanks everyone for ur help like i said all help is appreciated
 

·
Registered
Joined
·
291 Posts
clicking in your situation is likely the selenoid to starter functioning and that is good.

your symptoms suggest a starter problem.
im not good at explaining further starter diagnosis. much info under search.
perhaps others will chip in.
 

·
Registered
Joined
·
918 Posts
I always use the process of elimination when troubleshooting. Grab a multi-meter and check the voltage of your battery as a starting point. This will confirm the strength of your battery for sure. Should read in the mid 12's. Next check your terminals to make sure they are secure like suggested. They may have jiggled loose on your jaunt. If that checks out grab a rubber mallot and tap the starter - then try to start it. May take a couple of tries. If you get it to start, your starter is pretty much dead. If it doesn't start with these attempts you've narrowed down your search and your left with the ignition switch.
 

·
Registered
Joined
·
739 Posts
its probably the starter i had the same thing happen, try replacing the starter. it should fix the problem. :)
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
thanx guys i was able to push start it to car x and have it completly looked at need it done anyways because of other problems that i didnt feel like finding all of them out, this post should be closed i got all info i need
 
1 - 15 of 15 Posts
Top