Mazda MX-6 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
So I was drivin to school this morning and my speedometer sorta broke, it reads high and makes a plastic grinding noise, is this a common occurance, or do I have to swap clusters and are the na clusters the same as a gt, sorry if this has been discussed before, I'm doing this on my phone in class so I am not really able to search to well.
 

·
Registered
Joined
·
437 Posts
No The N/A cables are not the same as GT's. The N/A's are roughly 2" shorter with a different end on them. So I have experienced... Junkyard maybe?
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #3 ·
ok thanks, but i noticed that it seems to be temperature related now, it was in the single digits in the morning and when i left to go to work after school, there was no noise and my speedometer worked fine :shrug:
 

·
Registered
Joined
·
233 Posts
happens to me on cold mornings if i give the car a bit of a kick before its properly warmed up. Can also happen if you accelerating hard and hit a decent bump, itll start bouncing around and making that nasty noise and scare the shit out of everyone in the car. Mine just fixes itself because i cant be stuffed fiddling around with the speedo cable and what not.
 

·
Registered
Joined
·
4,150 Posts
my beater lx does the same thing if its really cold some times. all last winter it did it till the interior would warm up through the entire winter. this year it hasnt been a problem even once though.
 

·
Registered
Joined
·
437 Posts
I got super lucky and found a complete GT speedo cable at "pull-a-part". Mine didnt have one when I got the car... :(. They charged me a whole $7.50 for the cable and everything! I am not sure if there is a difference between "GT" and "GT AWS". I've seen 2 different kinds of speedo cables now. One has a flathead and the other is like a square peg.
 

·
Registered
Joined
·
4,150 Posts
the AWS's have a different sending unit. i know that much. so chance's are, the connector at the end would be different on the AWS. never actually compared them though. just assuming.
 

·
Registered
Joined
·
373 Posts
This is funny because my speedometer bounces when it cold and u can hear it ticking it just need some lube but i haven't got that far yet and I am using a speedo gear off a 90 mazda 626 turbo tranny (my part car) on my 88 626 manual turbo tranny, because i broke that tab off, the gear works good it just is really twitchy until around 65 then it is fine
 
1 - 8 of 8 Posts
Top