Mazda MX-6 Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter · #1 ·
My brake light on the wing hasn't worked since I got the car I was wondering how to get the brake lights out and what kinda lights are in there.
 

·
Registered
Joined
·
173 Posts
i think you need to get in there with likea 90 degree angle screw driver cuz i think underneath there are two screws. i don't know though, just a thought.
 

·
Registered
Joined
·
95 Posts
Discussion Starter · #4 ·
Why do you say that?
 

·
Registered
Joined
·
1,306 Posts
Actually it depends if you r spoiler was aftermarket ot stock. Some of them have the 2 screws underneath where the LEDs are and you can actually remove the LEDs. On MY stock spoiler for instance, since it was an aftermarket spoiler, it did not have the 2 screws so i was not able to remove the LED lights.
 

·
Premium Member
Joined
·
3,965 Posts
jdmxsix said:
there is 2 screws like he said. call mazda and you might not want it that bad. haha later

He mentioned that because the dealerships charges a rediculous high price... :(
 

·
Premium Member
Joined
·
3,844 Posts
Ruubstr94Ls said:
He mentioned that because the dealerships charges a rediculous high price... :(
Yeah Mazda UK wanted £309 nearly $450.
 

·
Registered
Joined
·
1,679 Posts
Ruubstr94Ls said:
jdmxsix said:
there is 2 screws like he said. call mazda and you might not want it that bad. haha later

He mentioned that because the dealerships charges a rediculous high price... :(
true, they will charge you an arm, 2 legs, and a few finger and toes for that LED. later man
 

·
Registered
Joined
·
95 Posts
Discussion Starter · #10 ·
Mine doesn't have any screws under it?
 

·
Registered
Joined
·
95 Posts
Discussion Starter · #12 ·
Yep that is exactly what it looks like. I tryed taking a flat head screwdriver and popping it out but didn't work.
 

·
Premium Member
Joined
·
3,844 Posts
Rather than trying to pop out the LED have you tried to trace the wires and connect them directly to 12V to see if it works. Might be just a bad connection somwhere else.
 

·
Registered
Joined
·
95 Posts
Discussion Starter · #14 ·
I don't think so becuase I can see some of the LED's popped out.
 
1 - 14 of 14 Posts
Top