Mazda MX-6 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter · #1 ·
Hey Guys,

I recently bought an MX-6, it had 230K on body and about 160K on the KLZE engine. It's a 97 so it has OBDII, no window switches.Previous owner said it had a new disty, he did tell me to change the plugs though. It also has a cold air intake, the intake has a prominent amount of oil in it (mostly due to the PCM tube). I don't think the oil in the intake is an issue, just normal blowby.

It takes several cranks to get it started. Usually i'd do 6 cranks and then stop and then re-try and it would start will 3 cranks the second time. Once it is running it works great. Except that the rpms get stuck at 1.3K sometimes after driving at 3K or something. I'm not sure that this issue is related. And if not I'd like to focus on the fuel issue.

Also you should note that when the car has been started and shut off it is fairly easy to restart it again withing about 30 minutes or so. It would only take 3-4 cranks. This points to a fuel pressure leak correct?

I'm fairly certain it's a fuel delivery/pressure problem.

Therefore i have narrowed it down to:
1) Fuel Pump (would it cause only hard starting?)
2) Fuel Pressure Regulator
3) Fuel Filter (Would it cause only hard starting? Car runs fine after start)
4) Fuel lines (would a leak in fuel lines be causing the de-pressurization?)
5) Also MAYBE injectors from the reading i've done it doesn't make sense that it is that..it drives great after start.

There are several tests used to check pressure of fuel, but i do not know how to do them, hell i don't even know where the fuel pressure regulator is...

Can someone guide me through what the possible cause of this is, and how to test many of the issues, i have a functioning donor car i can use beside it. So i can change switch like fuel pump, i'd like to narrow it down a bit...
I have researched but nothing really matched my problem correctly, yet i did take hints from other threads.
Thank you.
 

·
Registered
Joined
·
77 Posts
Discussion Starter · #3 ·
I will change spark plugs but i'm quite sure it's not a spark issue. Engine runs great after starting. It's a fuel issue. I'm going to be changing fuel filter next weekend, should be an easy job.
 
1 - 4 of 4 Posts
Top