Mazda MX-6 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
165 Posts
Discussion Starter · #1 ·
Usually I start my car in the morning and it hangs around 1100 rpms and then slowly goes down to 700 as it warms up. This morning it started right up and then just died, started it again and it just died. So i start it again and give it some gas and it will run fine with me giving it gas. Let off and it dies. I got out and adjusted the throttle screw and then started it and adjusted it to about 900rpms. It stays running, well as I go down the road it gets into it's normal running and the rpm's are up to 1500 in idle, this is because I adjusted that screw. i get to where I need and then put the screw back to the right spot and it runs fine. Any one think they know what it is? I only have one car and that is the only way for me to get around. I will let you know if it does it again after sitting a little bit. Thanks!
 

·
Registered
Joined
·
195 Posts
I had the same dying problems, as well as a very reduced performance in acceleration.

the problems was the timing belt , some pieces near it were gone and they had to replace the timing belt (100), pulley(150) and tensionner(190). Everything is fine now... but it did cost me a lot of $$$$$$!!!! they also changed spark plug & wire for NGK one (170).

Total for the invoice: 1089$
 

·
Registered
Joined
·
165 Posts
Discussion Starter · #3 ·
Well I know it's not the timing belt because I got it replaced about 15,000 and it looks fine. I did run a diagnostic check and I came up with 3, 17, 24, 25. Well my CEL only comes on when I'm in 5th gear and it is when I am going a set speed. It will just come on out of no where, then I let of the gas for 3 seconds and press it back in and the CEL will go off. Well 25 is the fuel pressure regulator, I don't know 24 but I'm sure it is something to do with 25. Then 17 is an oxygen sensor but it says to check the fuel system and ignition. Then 3 is a camshaft position sensor, and I read that it's in the disty and you have to replace the whole disty. I think that if it is the CMP then my CEL would be on the hole time. I reset the ECU and I am going to let it rest unitl tonight and then start it and take it for a drive try to ste the light off again and double check. I'll let you guys know, but what do you guys think?
 

·
Registered
Joined
·
165 Posts
Discussion Starter · #4 ·
Well tonight I went out and started it and it seemed to be fine. I went on to the freeway to see if I could get my CEL to come on and it tool a little longer than normal, maybe because I smacked the FPR a little bit. Well got home and did the diagnostic again and I only got 24. and 25. So it is the FPR but what is code 24? Also what would make a FPR go bad?
 

·
Registered
Joined
·
5,550 Posts
oxygen sensor

24 is RHO2S inversion error
 

·
Registered
Joined
·
5,550 Posts
It just means it is faulty and you have to replace it.. .. you can’t do much with them unfortunately.. and the rear one is the right one not the front.. :tup:
 

·
Registered
Joined
·
5,550 Posts
Funny that I used to call the rear the left for years till I was put straight..
It is easy enough to remember the Rear is the Right.. (R) ;)
 

·
Registered
Joined
·
2,664 Posts
The O2 sensor wouldnt cause him to have his car not run would it?
 

·
Registered
Joined
·
5,550 Posts
I’m sorry I thought you had it sorted out, Well it may… .. if the PCM is not receiving a signal from the o2 sensor it will go to fail safe mode and perhaps the throttle idle air etc is not set properly to allow enough air in on failsafe.. thus staling..
I recommend getting a replacement o2 sensor resetting ecu and then resetting/adjusting the TPS idle and timing .. how to in the FAQs…
Good luck..
 
1 - 13 of 13 Posts
Top