Mazda MX-6 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
193 Posts
Discussion Starter · #1 ·
Tonight I went to pick up my sister from her school play. It's pretty cold outside, 40 degrees, I drove the car lightly, giving it ample time to warm up. On the way home I was having a little fun, not speeding or pushing the car to it's limits, but still not driving normally. When I got home I noticed steam rising out of the engine compartment, I popped my hood and It was coming straight from the engine. I think it's because of the near freezing temperatures and the hot engine. The check engine light never came on, oil is fine, and the car was running like normal. Anyone else ever experience this?
 

·
Premium Member
Joined
·
7,196 Posts
I have, but it was on the highway after a good period of high speeds. I was running late for work on my way home from a trip, and made it on time:D

After I got off the higway, it started doing that. I opened the windows, turned the heater on full blast, and checked everything when I got home. Everything was fine, and I watched it very carefully over the next few days. Haven't had any problems with it that I know of.
 

·
Registered
Joined
·
193 Posts
Discussion Starter · #4 ·
Found the problem this morning. When my car warmed up I had antifreeze leaking all over the place. The cap was loose and leaking, dripping it onto a belt that was flinging it everywhere causing steam, and steam straight from the cap. Tightened the cap, no more steam woohoo. But now I have an oil leak that's been off and on since I got it in August, need to fix it, are there any common places where oil leaks from?
 
1 - 4 of 4 Posts
Top