Mazda MX-6 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter · #1 · (Edited)
Well its been like two or so months trying to get everything I wanted and needed. Then some delays due to some bad subs and such but got everything working just right. Except the lights Dimming, majorly.

Got Polk speakers
Sony Head unit
Hifonics BX11608 (1-ohm 1600 watt rms)
Two 12" Kicker CVX's wired to 1-ohm
Sealed dual chambered box with 1.3 cubic ft per chamber
Oh and my ipod playin the tunes.

Here are the Pictures. Oh and Yes I know I need to clean it I haven't had time. And its only 40 outside now.



My Amp


Double 6-gauge Power and Ground


Rear Deck: Polk 6.5"


Front 5.25" Polks Stuffed in there Tight


DX to LX conversion




Sub and Battery Box 12" CVX's


How I fixed my Subs from pushing air onto my Speakers
 

·
Its not butter?!!!!1
Joined
·
4,968 Posts
Sweet. Looking good!! I'm glad the whole install went great.

Whats next? or are you done now?

I still have to post pics of my install in the Z4.. should have it up in a few days.
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #4 ·
Well now I'm looking for how to get a higher output alt. And cleaning some stuff up like hiding wires and such. And finally cutting the rear deck some to put the speaker grills in. Would like to install a small amp to power the Polk speakers. Need like 4x50 rms. But need some more juice from the alternator first. Oh and I did the big three with comercial grade tractor trailer wire (4-awg).

I'm trying to see if a alternator place can rewire it to put out more amps. But I cant find any real information that is helpful. I'm searching the forum right now in the 1g section.

Oh and we need some pictures of urs Graham I mean everyone should see your still pounded with an old school amp.
 
1 - 4 of 4 Posts
Top