Mazda MX-6 Forum banner
1 - 20 of 80 Posts

·
Registered
Joined
·
3,858 Posts
Discussion Starter · #1 ·
Okay so this is it before I send my car to Ford and lose an arm and a leg and maybe my right nut....

The car is still dying in warm weather when I put the boot in at about 4,500-5000rpm this is the list of what I have done...IN colder weather probably 15 and udner the car boosts fine and runs liek a dream only in warmer weather (particularly during the day) does it stuff up.


Repalced Leads
Repalced and regapped plugs
Removed Boost Controller
Remove Pod and Repalced with Standard filter and Airbox
Cahnged Fuel Filter
Reset ecu (numerous times)
Ran through 2 bottles of injector cleaner
Changed fuel comapines
Played with timing
Removed bov repalced with standard
Checked for vacum leaks
Cleaned EGR
Cleaned vacum liens and did a carbon clean
Removed CAI
Checked O2 Sensor
Played With Idle
Played with a/f mixture

Someone help me :) Please!!!!!!!
 

·
Registered
Joined
·
1,334 Posts
zorb, well I believe I have simliar problem if not the same. If you figured it out let me know as well, thanks. I just changed my timing belt andnow when I floor the accel. even now that it is not hot, it wont goes as even a stock should...and also this vib./shaking noise in the engine which I believe is from the timing belt area....

could it be the fuel regulator? maybe some fuel issues or not enough fuel going in...?

I feel like mine is cutting out like not enough fuel...have you done the air/fuel ratio test and see if there is enough fuel going in? well I havent done that yet....
 

·
Registered
Joined
·
1,334 Posts
Did you check your ignition timing when you changed the timing belt? Just something to think about.
what do you mean? if you mean the number one cylinder mark on the top while the mark on the pulley is on TDC or "T" mark, yes I have done that but I am not sure how tight the belt must be....I did kinda tighten it as it was before but now its making strange vibrating/shaking noise at higher revs...well when the engine is on you can hear the constant noise but when you rev up you can feel it as if the belt is struggling or something and wants to come off, well i dont know how exactly to describe it....

zorb, looks like its very complicated, I cant believe that you still havent found the problem, well i should be telling myself a "Good luck mate"....
 

·
Registered
Joined
·
1,334 Posts
ahh man you have done all the possible tests and still no luck....i feel for you bro cause I have similar problems....I just did my timing belt and water pump and followed all the rocedures and instructions but still its being funny....no power and when I give it a kick it wont go and make this loud shaking/vibrating noise...god knows whats up with my ride now....you fix one thing, another goes wrong...hahahahaha
zorb_rules said:
Okay so this is it before I send my car to Ford and lose an arm and a leg and maybe my right nut....

The car is still dying in warm weather when I put the boot in at about 4,500-5000rpm this is the list of what I have done...IN colder weather probably 15 and udner the car boosts fine and runs liek a dream only in warmer weather (particularly during the day) does it stuff up.


Repalced Leads
Repalced and regapped plugs
Removed Boost Controller
Remove Pod and Repalced with Standard filter and Airbox
Cahnged Fuel Filter
Reset ecu (numerous times)
Ran through 2 bottles of injector cleaner
Changed fuel comapines
Played with timing
Removed bov repalced with standard
Checked for vacum leaks
Cleaned EGR
Cleaned vacum liens and did a carbon clean
Removed CAI
Checked O2 Sensor
Played With Idle
Played with a/f mixture

Someone help me :) Please!!!!!!!
 

·
Registered
Joined
·
2,328 Posts
Thats the cam timing which you have lined up there. Ignition timing is adjusted with the distributor and a timing light.

I think you check if the belt it tight enough by the deflection. I did it a few years ago and cant remember anything specific.
 

·
Registered
Joined
·
3,858 Posts
Discussion Starter · #8 ·
well checked all that I have no diea dont an a/f test midn you onyl using an a/f gauge so not the accurate but its a start Im all outta ideas..oh well there goes my right nut...
 

·
Registered
Joined
·
3,858 Posts
Discussion Starter · #10 ·
absically when I plant the foot to say overtake or soemthing the car hits around 4,500-5000rpm and just dies drops back to probably 1500 revs...ist like the enigne just shuts off momentarily..Its kind of liek boost/fuel cut but without the annyoing beep from the computer and all that...I knwo its not boost cut because I still hi that occasionally and the beep occurs..both LXSS and Sabbai having driven it maybe they coudl explain the problem a lil better
 

·
Registered
Joined
·
7,061 Posts
drop the boost first and find out if it's being efffected take it to 7 psi.

If it does not happen my guess is your blowing out your spark. either because your lossing power to the plugs bad plugs or the ignition module is a failure.
 
  • Like
Reactions: cam22t

·
Registered
Joined
·
3,858 Posts
Discussion Starter · #12 ·
ive done that rod I removed bosot controller all together so its back to whatever the standard was..still no difference..is there a way to drop boost further
 

·
Registered
Joined
·
2,328 Posts
If the tacho is dropping like the car is dead it might be a loom short somewhere. I have had that before. Might be a naked wire grounding on something when you accelerate hard. Thats an unlikely tale though, but its one of those sorry ones I have had before!
 

·
Registered
Joined
·
5,273 Posts
zorb i had similar probs with my old 626 turned out to be fucked ignition switch, corner hard and it cut out flick witht he switch and it turned back on..

maybe be similar but i doubt it.

is it only at wot ? maybe something like fruited tps ?
 

·
Registered
Joined
·
1,334 Posts
timtx5 said:
Thats the cam timing which you have lined up there. Ignition timing is adjusted with the distributor and a timing light.

I think you check if the belt it tight enough by the deflection. I did it a few years ago and cant remember anything specific.
ahh I c...well ignition timing shouldnt be messed up by just changing the timing belt...or would it? I think I need a full on tune up...but I am getting worried cause zorb still has issues with his ride and im affraid maybe mine is gonne be like that or worse.....
 

·
Registered
Joined
·
1,334 Posts
zorb_rules said:
ive done that rod I removed bosot controller all together so its back to whatever the standard was..still no difference..is there a way to drop boost further
i dunno if you can actually lower the stock boost as well...

I wish I was there to take a drive and see how exactly it is....

have you tried a different ECU at all? maybe that would be another cheap alternative to give it a go.....as others also said by the sound of itas I think about it it could be ECU or Ignition module...

as I said I have similar problems even now that i did the timing belt and water pump, and I have no idea....

I remember on my previous car I reset the ECU and noticed a bit of power loss....and since then I was telling myself why there is no power anymore....maybe I got used to the car, but one thing i'de never do is to reset the ECU unless really have to....
 

·
Registered
Joined
·
3,858 Posts
Discussion Starter · #18 ·
the problem thats gets me is in the cold the car runs fine things liek shorts etc...arent effect by temperature are they it all doesnt make sense *loL*
 

·
Registered
Joined
·
1,334 Posts
well the short problems ofcourse aint affected by temp as far as I know...so you have heat problems....you gotta figure out what things on/in the engine are would be affected by heat and temperature....you gotta write them all up as much as you can think of...then check each one indivisually.....

I'de probably try a different ECU, dont worry about reseting it...just try another same model ECU and see how you go....

have you had it fully inspected by specialists like mazda motors or I dunno some performance centers? i know they charge heaps but for just inspecting they shouldnt be expensive....i reckon that way you save lots of headaches and as soon as you found the problems you can fix'em yourself...

I am actually surprised rather keen to know what is the problem with your car cause it sounds strange and actually really interesting....best wishes mate....looks like me and you got ourselves a puzzle to figure out...good excersize for the brain....lol...
 
1 - 20 of 80 Posts
Top