Mazda MX-6 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
Ok....I have two things going on right now with my MX6 that, quite frankly, puzzle the shit out of me.

1) "Intermittent" Wipers: What I mean by this is sometimes they work, sometimes they don't. Sometimes when I go to use the wipers, they won't work, and neither will the windshield washer fluid pump. When this happens, I'll pull over, and keep restarting the car until they work (sometimes I only need to do this once, sometimes it takes 4-5 tries) Obviously its electrical (if the wiper motors were broken, the wiper fluid pump would still operate, right?) Any idea where I can start looking to fix this?

2) My blower fan is completely on the fritz. It works fine on settings 1 and 2, but as soon as I put it on 3 or 4, it will quit working all together. I'm not sure if its an issue of wires in my HVAC control, or if the blower isn't getting enough power, or if the blower itself is broken (well, relatively speaking)

Any help would be GREATLY appreciated.

Thanks in advance ;)
 

·
Registered
Joined
·
405 Posts
i am not sure what the deal is with you wipers. i do know what is up with your blower though. there is a resistor for your 3 and 4 speeds that has gone bad. you can do it yourself or take it to the mazda dealer. i paid to have mine fixed b/c i had no clue what it was. i think i paid like 70 bux. there is people on this board who have changed it, and i think they paid like 5 bux.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #3 ·
Any idea where the resistor's located? I'll replace it myself if it doesn't cause me the extra $65 of agony to get at it. Otherwise, I can change a resistor.

Thanks man... I was probably going to try ripping a blower unit from the junkyard next. Sounds to me like it wouldn't have made things work anyway.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #4 ·
lol, again the merits of being half awake...I worked 3rd shift last night and just woke up... I didn't see the "i had no clue where it was located" part.
 

·
Registered
Joined
·
19 Posts
heatseeker151 said:
Any idea where the resistor's located?
i had to replace mine too. i dont know exactly where it is, right know, ill check in the morning and post it. I do know its under the glove box, you take off the paneling under the glovebox, you will see the blower moter with with wires coming out of it, follow the wires to the resistor. Ill check in the morning for exactly wich wire.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #6 ·
thanks a lot, man... is it a resistor like you can purchase at Radio shack? or a mazda part... can you try to get either the resistance of it or a part number so I can find one? Thanks
 

·
Registered
Joined
·
291 Posts
resistor module

as bergd said, remove plastic panel under glove box. near firewall and near pass side see 2 wires entering a vertical mounted module about 3 inches long held by 2 screws. remove and you will see 4 resistor wires. at least one of which will be burned through.
cost is $60 at a mazda parts department, but total fix time if you know location is 10 minutes.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #8 ·
Yeah, I checked with Lindgren Mazda in Reading, PA today. It was funny... When I got to the dealership, I noticed a red LX parked in the parts lot, when I went in I noticed a guy standing in line at the parts counter looking at the owner's manual for the 626/MX6 open to the HVAC controls page as he was talking to the parts guy. I overheard him explaining his problem to the guy at the counter, about how when he puts it on settings 3 or 4 it will stop blowing air. The guy at the parts counter grabbed a new blower SWITCH and told the guy that this was what his problem was. Bizarre, yes the guy in front of me had my exact same problem, but I needed to step in and regulate. That parts guy had NO idea wtf his problem was, he would have sold that poor sap the switch for $85 and it wouldn't have fixed a thing. Anyway I explained about the resistor to them and the guy at the counter said "well... you never know... the switch MIGHT be broken..." Right.

Man, why does getting parts from dealerships have to SUCK SO BAD?
 

·
Registered
Joined
·
512 Posts
Goto the junk yard man. The part could be had for cheap. Plus you don't have to deal with anyone.
 
1 - 9 of 9 Posts
Top