Mazda MX-6 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter · #1 ·
so today i started up my car. idle was a bit rough but i thought nothing of it. later on my drive it started to get rougher and it also began to drop idle revs to about 500rpm and kept going until i had to keep the car revved in order for me to keep going. as soon as i got home i shut off the car and immediatly tried to start it back up but absolutly nothing happened except for all the warning lights came on. so i waited about 10 minutes and it started back up but idles a bit rough. anyone know whats going on? im scared for my baby:(
 

·
Registered
Joined
·
189 Posts
i got a question to some times after i been driving for a little bit it will drop then go up drop go up but when i start driving again its fine it will go up to about 1700 down to 800 until i take off again
 

·
Registered
Joined
·
2,227 Posts
should check tps and maybe your alternator. my alternator recently died and the car would idle high because it would try to get the alternator to a point where it would actually charge the car. keep an eye on your charge light. after I changed my alternator, my car would idle correctly but will still occasionally idle high randomly warmed up or not. might as well get it tested at an auto store along with your battery maybe
 

·
Registered
Joined
·
737 Posts
i got a question to some times after i been driving for a little bit it will drop then go up drop go up but when i start driving again its fine it will go up to about 1700 down to 800 until i take off again
are you saying everytime you come to a stop (and idling) your rpm's rise and fall over and over again? if that's the case sounds like a vacuum leak. :)
 
1 - 6 of 6 Posts
Top