Mazda MX-6 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
i was driving home from work like every night and i smelled something weird in the car. i looked down at the gauges to see if anything was wrong and the coolant temp was pegged at the bottom. i pulled off to check the coolant and everything was fine, no leaks or anything. i started it up and then the tach died and the weird smell came up again. i was thinking that a fuse blew but the gauge and backup light fuse was fine. any suggestions would really help.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
well, i checked all the fuses, including the meter fuse and everything looked fine. then i checked all the fuses under the hood and they were fine too. just to make sure i replaced the meter fuse with the spare, started her up, and the tach still didn't work. the funky smell came up again and now i'm a little worried. just for no reason in particular i checked the oil level and it ridiculously low. so now i'm worried that the smell is the engine cooking itself (but the smell only comes from inside the car, not under the hood). i did a search and came up with nothing. so i'm just gonna take it to my mechanic and have him look at it. if anyone knows what possibly could have gone wrong, any suggestions would help.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
finally had some time to take apart the dash last night to look for some fried wires. guess what? none to be found. so i'm kinda angry that i just spent two hours checking and rechecking for dead wires. i call my mechanic to see what he can tell me. i tell him the story and he's stumped. finally i just bring it up to his shop and he looks around for an hour to find the entire instrument cluster shorted out. moral of the story: i have never no will never be able to solve an electrical problem in my life :mad:
 

·
Premium Member
Joined
·
7,067 Posts
yeah, electrical problems suck. just sold my old car (Dodge Spirit) that had a problem where whenever you'd hit the left turn signal, the radio would go off. : \

Trent
 
1 - 7 of 7 Posts
Top