Mazda MX-6 Forum banner

41 - 60 of 70 Posts

·
Registered
Joined
·
47 Posts
I am planning to do the KLZE swap soon, was wondering where the ECU location is. I want to take it out and I plan on getting the Probinator Chip, unfortunately he hasn't responded. I'm hoping he still produces them.
 

·
Premium Member
Joined
·
1,988 Posts
petoria said:
I am planning to do the KLZE swap soon, was wondering where the ECU location is. I want to take it out and I plan on getting the Probinator Chip, unfortunately he hasn't responded. I'm hoping he still produces them.
The ECU is located behind the ash tray. Pop off the center console piece around the shifter as well as the plastic side pieces to access the screws holding it in.
 

·
Registered
Joined
·
841 Posts
i ran into a little problem today when i was installing my wireing harness. it seems some clips on the harness seem to not go to anything. is this the diffrence between OBDI and II. my car is a 94. im not sure the year on the ZE i baught i dont have the papers in front of me. but say if i had my 94 car and a 97 engine would wireing harness match right up? this may just be me being dumb and not being able to find everything
 

·
Premium Member
Joined
·
1,988 Posts
A 97 KZLE is OBD1. Even a 97 ZE is wired as OBD1. The harness does not match up. If your ZE has 3 coolant sensors then you could get a 93 harness and everything would be plug and play. I got lucky and got a ze with 3 coolant sensors and as I had a 93 I had virtually no problems with the install.
 

·
Registered
Joined
·
841 Posts
im going to go look now and see if it has 3 coolant sensors. so if it does your saying i need to buy a 93 wiring harness? how would i go about that? autozone maybe?

edit-- yup i have 3 coolant temperature sensors. AWSOME now i need a new harness to. what about my ECU now?
 

·
Premium Member
Joined
·
1,988 Posts
I believe if you keep your 94 harness it will still work but you will throw a CEL for the lack of the 3rd coolant sensor on your harness. A 93 harness would solve that issue.

PM Hughes on the harness. Tell him your looking for a 93 with 3 coolant sensors. As far as the ECU goes, you can use your stock OBD2 ECU but you'll need a chip. I'm not 100% certain with this as I never had to deal with these issues. I'd contact probinator and find out what he has. He sells chips that you can solder on your ECU that will adjust for the fuel and timing difference. I'd recommend you get verification on what I'm telling you too, I'm fairly certain but I don't want to steer you wrong.
 

·
Registered
Joined
·
1,646 Posts
i dont have a chip for my ze and its in a 96 and as far as the extra coolant sensor just pull the coolant neck off your klo3 and bolt it on 93 is the only year that came with the 3 sensors as far as i know
 

·
Registered
Joined
·
4,939 Posts
My KLZE is a 1994 model and it came with the extra coolant sensor so mine was plug and play as well. Early 1994 ZE in 93 mx6.
 

·
Registered
Joined
·
5,550 Posts
Just swap the sensor housing from your old one including the sensors.. it is a separate part…
2 bolts and pull from memory (it is an o ring seal ) it may have been easier with the motor out of the car but it can be done in the bay. May have to remove the intake..
 

·
Registered
Joined
·
841 Posts
i dont have my old engine anymore. my dad made me get rid of it. sooo now what? and also the harness plug for the EGR doesnt fit. or i was tryiong a wrong one maybe im not sure im getting all confused now.
 

·
Registered
Joined
·
841 Posts
ok well basically i need to know, will my car start and run with everything im able to hook up? i dont like wires so i would like to see if a shop around here could install a 93 harness for me but id like to drive it there and not pay for towing.
 

·
Premium Member
Joined
·
1,988 Posts
Yes your car should run just fine. It will have a CEL and you'll have the wrong fuel mapping as the ze has a higher compression and requires different fuel mix but it will still run fine. My ze is running on my aspec ECU and Vaf as I still have not got around to installing my chip. It still has great power though but from what I hear once I get the chip installed it will be noticably quicker.
 

·
Registered
Joined
·
841 Posts
the fuel mix would be the chip right? if so im planning on sending my ECU off to probinator to get that done.

i really think i could live with a check engine light on. for a while at least. since i only have my permit im not going to be driving everyday.

theres 2 wires i know that i cant find anything that hook up. one is the EGR, the plug is sort of the same size but doesnt fit. and the other is setting below the VRIS and it has a yellow inside and 1 prong. anyone know what it is? i may just not see what it hooks to.
 

·
Premium Member
Joined
·
1,988 Posts
the fuel mix would be the chip right? if so im planning on sending my ECU off to probinator to get that done.
Thats correct. The chip will solve the issue. As far as the EGR, I swapped mine over to the ZE and left it connected to avoid a CEL. It doesn't weigh that much and I didn't want an annoying red light on the dash. Not sure about the plug though.
 

·
Registered
Joined
·
841 Posts
i cant remember if i saved the EGR or not i hope i did so i just can do that and then i might not need a new harness. do you think probinator could make my ecu think all the coolant sensors r plugged in? ill pm him. and last but not least will my temperature gauge work without all 3 hooked up?? sry about all the questions i want to be absolutley sure
 

·
Registered
Joined
·
841 Posts
ok thanks a lot david! im hoping to have it running in a few days time!!!
 
41 - 60 of 70 Posts
Top