Mazda MX-6 Forum banner

1 - 15 of 15 Posts

·
Premium Member
Joined
·
1,301 Posts
Discussion Starter #1
Yes it has a five speed. The gas tank does not leak. Pics are in my sig. I did hit white deer and it has minimal body damage. Rust around the windsheild. No leaks. Everything works as it should. I would trust it to drive across country. After market exhaust. Insane handling and cornering, this is a one of a kind car. In North America we only got white, automatic 4ws 626s. This is the only 626 4ws with a five speed i have ever seen. I have been driving it for the last three years. Selling b/c my parents gave me a camry and i have no need for any car atm. Turbo timer, 2.5 exhaust, msd, newer sus, whl br, eibach lowering springs, sway bar kit, axles, tie rods and lower control arms (inc ball joints) quick windows and super clean interior.
 

·
Registered
Joined
·
2,228 Posts
yea, I love how this always happens!!!

I just bought a 89 626 hatch.........

damn, I would have bought yours for 1500 in a heartbeat......

CRAP!!!
 

·
Premium Member
Joined
·
1,301 Posts
Discussion Starter #6
yea, I love how this always happens!!!

I just bought a 89 626 hatch.........

damn, I would have bought yours for 1500 in a heartbeat......

CRAP!!!
is it rusty? if it is clean i would trade....
 

·
Premium Member
Joined
·
1,301 Posts
Discussion Starter #9
Didnt you have .. alot of spare parts for the 4ws?
I would like to think i have more then any other member. I have spent the last 4 years collecting them.

I am serious about selling the car. My parents are giving me a camry if i sell my mazdas.

What do you need for parts?
 

·
Banned
Joined
·
4,087 Posts
Thats actually on thing I dont have. But you can order it from MAzda.


I do actually have one, but its just for research purposes (ITs SUPER rusted out). I didnt feel like dropping the tank at the JY otherwise I would have grabbed the one out of the 4ws there...
 

·
Registered
Joined
·
3,379 Posts
well im not sure which one is bad (both are different from the 2ws one btw) and all i know if under half a tank the gauge drops to E. ill have to test which one has resistance and which one is just open.
 

·
Registered
Joined
·
415 Posts
I'm not sure what I need yet, I hope to god that the rack isnt a goner, but I cant be sure untill its all hooked up again, gonna remove the seats and look at boxes and wiring soon, and I'll probably buy new pipes from mazda...
 

·
Premium Member
Joined
·
1,301 Posts
Discussion Starter #15
I'm not sure what I need yet, I hope to god that the rack isnt a goner, but I cant be sure untill its all hooked up again, gonna remove the seats and look at boxes and wiring soon, and I'll probably buy new pipes from mazda...
the pipes on the rack and the timer unit is all i have done to my 4ws 626. i did both at the time i bought the car 4 years ago and i haven't had a single problem with 4ws working, never quit on me.

Except once....if it was super cold out and i let the car warm up (by holding the gas at 2k rpm) and the light started flashing. I turned if off (the car) and it worked fine after that. So just a heads up, but the past winter it worked flawless.
 
1 - 15 of 15 Posts
Top