Mazda MX-6 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
375 Posts
Discussion Starter · #1 ·
This sucks I think I blew a hole in my block. I turned up the boost to 15psi, and was doing fine, until I got home. I went inside for a couple hours thinking all was well. I went back outside, around 12 pm to find all my engine oil under my car. So I pop the hood, and find oil splatterd everywhere. I couldnt realy check it cause it was dark and very mad, but could tell the oil leaked from the back of the engine. My question is where could the oil leak from if I didnt blow a hole in the block? One of my friends said it could be the rear/front main seal. I still dont know if it starts cause the engine has no oil. Any help/info would be appreciated.
 

·
Registered
Joined
·
512 Posts
Oops! You turned it upto 15psi with no chip? While I dought you blew a hole in your block I'm sure your motor didn't enjou the event any. But check around and find out where the oil is coming from. Someone one probetalk blew his oil seal and it took the dude 6hrs to change it. But there are so many seals the have potential to leak I'd start looking around. Dump some oil in it and see where it leaks [email protected]
 

·
Registered
Joined
·
1,601 Posts
Verify that it is oil and not grease from a CV. Then check your oil cooler. This is right were your oil filter attaches to the car.
 

·
Registered
Joined
·
287 Posts
I don't think a CV boot holds 4 quarts of grease dude :) Start from the top of the head and start knocking off options. Like start from the valve cover gasket and work your way down the oil parts path.
 

·
Registered
Joined
·
287 Posts
I think if he were running high RPMs and had a good size valve cover gasket leak (or lack of PCV valve) the oil would have potential movement inside the engine.
 

·
Premium Member
Joined
·
3,962 Posts
Oil filter maybe? Distributor seal? Did you hear any funny sounds when you were boosting at 15psi (i tried that once, and got immediate detonation).
 

·
Registered
Joined
·
375 Posts
Discussion Starter · #8 ·
I didnt hear any funny sounds, like detonation. I havnt had time to check it cause of work, but will tommorow. Thanks for yalls input.
 
1 - 8 of 8 Posts
Top