Mazda MX-6 Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hi,

I am just new in this forum. I just bought a 1994 MX6 LS yesterday at $750.00 canadian. The car failed air care that is why it is cheap. I use to 626 in the past which i really like and at present I own a B2200 1988 which I also like.

I bought the MX6 because it is MAZDA and I like the style.

While driving the car home last night, I have notice that the transmission mulfuction light turns on and off. I have check the manual. The manual states that if this light shows a problem in the engine electrical system.

Can anybody in this forum direct me to what I need to look at to correct the problem? Do I have to have it scan? The car shifting properlly when I was driving it home.



Thanks,

Raul
 

·
Registered
Joined
·
954 Posts
While driving the car home last night, I have notice that the transmission mulfuction light turns on and off. I have check the manual. The manual states that if this light shows a problem in the engine electrical system.
By transmission malfunction light, do you mean the "hold" button ? (i assume it's an ATX) from what i understand, the check engine light would indicate problems with the engine electrical system.

here's some info on retreiving engine codes

1993-1995 Engine Controller Malfunction Codes

and transmission codes

1993-1997 Probe & MX-6 Maintenance

when retrieving transmission codes, the "hold" light will flash just like the check engine light so when you check for those, look at the "hold" light instead of the check engine light

hope this helps
 

·
Registered
Joined
·
1,050 Posts
Have you checked the code for the CEL?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #5 ·
The lights that thurns on is the transmission symbol on the dashboard. This goes on and off when driving. It seems goes away when at low speed. This is not the ovedrive symbol. I can feel the transmission shifting properly.

Thanks,

Raul
 

·
Registered
Joined
·
35 Posts
Are you sure that symbol isn't an engine rather than a transmission? I've never heard of a transmission symbol, at least not on US cars. Sounds like your check engine light is coming on and off. As noted above, you need to check your codes to see if any are stored.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #7 ·
Are you sure that symbol isn't an engine rather than a transmission? I've never heard of a transmission symbol, at least not on US cars. Sounds like your check engine light is coming on and off. As noted above, you need to check your codes to see if any are stored.
Sorry, I have mistake in stating transmission. After care search. It was actually a symbol for check engine light. I will have to bring to a shop to havethe codes retrieve. The light goes on and off whil i was driving the car home when I got it. I have not driven the car since then. Since I am still working on it. At present I am waiting for thoxygen sensors before I will bring it for aircare. This might be the problem that cause the engine light to turn on and off since it failed aircare.

Things I need to do for this project car:

Repalce O2 Sensor

Replace transmission fluid and filter

Check valve noise in the rear engine (fire wall side) The valve makes noise when it is cold and reduces noise when warm) Seem to be oil not reaching the valve rail. What can you suggest? I already added additive to quite valve. Did not work.

Repair or replace rear center breaklights at the spoiler. When can I buy this.

Repair Antenna.

Replace plugs.

What else do you think I need to check.

Thanks and sorry for the mistake.

Raul
 

·
Premium Member
Joined
·
5,189 Posts
If you search the site here, you'll see how you can check the engine code yourself without taking it to a garage.
 

·
Registered
Joined
·
954 Posts
Check valve noise in the rear engine (fire wall side) The valve makes noise when it is cold and reduces noise when warm) Seem to be oil not reaching the valve rail. What can you suggest? I already added additive to quite valve. Did not work.
If the valve clatter goes away after a while it's normal HLA noise (the shop manual says ~20 minutes depending on the oil condition and ambient temperature, in my experience though it usually goes away within 5 min)

just go the first link i posted in post #2 for check engine light codes
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #12 ·
As mx6Remix posted right before your post, just go to post #2 in this thread and click on the link that he had posted there: 1993-1995 Engine Controller Malfunction Codes
I just replace the two sensors last week. Everything is good. I pass the air care. Check engine light is gone.

I also tested the car. This care is still kicking at 140 KM.

Can anyone teah me how to post pictures?

RP
 
1 - 13 of 13 Posts
Top