Mazda MX-6 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
372 Posts
Discussion Starter · #1 ·
I have an electrical problem, i have narrowed it down to the top 30A fuse in the underhood fuse box, whatever is on that circuit it draining the batt in about a day, the only problem is that the sticker that belongs on the top of the box it not there and i don't know what that fuse is for, does anyone know, or is willing to go look on their car for me, i have an 88 MX6 GT. Thanks
 

·
Registered
Joined
·
897 Posts
Top fuse (furthest from the radiator) on mine says EGI.

I have no idea what that is, but mine is a '88 GT also.

The other 30A fuse says HEAD, and is below the EGI one, both on the right side.

This is the box in the engine bay.
 

·
Banned
Joined
·
4,040 Posts
Illswyn said:
Top fuse (furthest from the radiator) on mine says EGI.

I have no idea what that is, but mine is a '88 GT also.

The other 30A fuse says HEAD, and is below the EGI one, both on the right side.

This is the box in the engine bay.
EGI = electronic gas injection (some might like to call it electronic fuel injection)
 

·
Premium Member
Joined
·
7,327 Posts
The EGI fuse powers several things; namely the fuel pump and fuel injectors. I don't have my manual with me right now so I can't check details, but check for damage to the fuel injector wiring harness. Sometimes the connectors get old and will short to the engine block.
 

·
Registered
Joined
·
372 Posts
Discussion Starter · #5 ·
thanks

Thanks for the info, but how should i go about checking the connectors(wouldn't that mean the injector would always be firing?), just to see if they are in good condition? Also if you guys could be so kind to post other possible problem/shorts with the "EGI" fused circuit.:help:
 

·
Registered
Joined
·
10 Posts
Hi, i am IROC5spd but this board is so weird that i have to use this name to log in at my house and the IROC5spd to log in at my g/f house, where the car is. Does anyone know anything more then that? This is an MX6 message board. Some one give me a clue here. Thanks for all that reponded already.
 

·
Banned
Joined
·
4,040 Posts
88GT_turbo said:
This is an MX6 message board.
Most of us had already figured that out.
 

·
Registered
Joined
·
372 Posts
Discussion Starter · #8 ·
well the injector for cyl number 4 has been messed with, look slike the connector was broke and the guy who had the car before us just put some wires in there and some kind of goo around it, could i get more info on what it would take to get a slow drain off the battery there...like if the wires are touching or something...anykind of trouble shooting info would be great. I don't fully understand what would be causing the short. If the car is off shouldn't that disconnect that circuit? Do you guys see what i am saying?
 
1 - 8 of 8 Posts
Top