Mazda MX-6 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter · #1 ·
Guys,

My car radio sometimes shuts off, well the radio stays on but no sound comes from the speakers. it does this randomly especially when it is hot.

Now the weird thing is when the sound goes away , i can make it come back on for a bit by turning on my windshield wipers !!!!

what in heaven;s name do wipers have to do with speaker wiring ???

any ideas ?

Thanks in advance.
Gullwing
 

·
Registered
Joined
·
69 Posts
Don't know if this'll help but I had a problem that caused the windshield wipers and A/C clutch to not work sometimes. I'd turn the car off then back on it usually that'd fix it... one day I just jiggled the ignition key and they worked.. ignition switch going away..
 

·
Registered
Joined
·
1,636 Posts
I had a problem with my CD player overheating and causing it to shut off. The problem was the temperture adjust lever was stuck all the way over to the Warmer (red marks) on the dash where you control the inside temperature (on my oldsmobile - it was controlled by a pully as opposed to electronically on the mx-6's). Does the inside of the car get warm when you are driving? If it is, you might want to check that system out. And the obvious, do you have the correct amperage on your fuse on your Constant power cable which is usually orange or yellow (disregard if you have one built in on the back of the deck). As for your cd player turning your sound back on, I don't know. Check all the speaker wires behind the deck and make sure no stripped wire is showing. I don't know if the Wiper wiring is close to where the head unit housing is but make sure no stripped wires are making contact with anything.
 
1 - 3 of 3 Posts
Top