Mazda MX-6 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
801 Posts
Discussion Starter · #1 ·
this puzzles me. OK, one day the LED brake light on my supra style #123 wing was working fine. the next day, my dad followed me home in his pickup, and when i park my mx6 and get out, he says to me "Why doesn't your spoiler brake light light up anymore?" it stunned me too. any suggestions?

thanx

-dogg
 

·
Registered
Joined
·
2,664 Posts
How many bulbs does it have? Sometimes when one burns out it sends to much power to the other and then the second one burns out also.
 

·
Registered
Joined
·
61 Posts
Maybe 1 LED is somehow broken (it most likely isn't burnt out the have a 100,000 hour life or something like that). If your LED bar is hooked up is series you just need to replace that LED. If your LED bar is hooked up in parallel, maybe it's a wire is loose, try pulling on them inside your trunk (don't pull to hard) if no wires come off then it's not that. Or did you check the fuse box? One fuse might be blow, then all you need to do is replace that fuse.
 

·
Premium Member
Joined
·
3,955 Posts
CustomMX6 said:
How many bulbs does it have? Sometimes when one burns out it sends to much power to the other and then the second one burns out also.
Burning one LED won't cause the rest to burn, if the circuit is in series then burning the first one will cause an open on the circuit and nothing will work. If the circuit is in parallel then every one will work except that burned out LED. Since the whole thing doesn't work then you might have a burn LED somewhere in that wing, you might have to test it individually see which one is burned. If all of them are fine then some wire might be lose.
 

·
Registered
Joined
·
801 Posts
Discussion Starter · #5 ·
i told an electrician friend of mine about it and he believed that a wire must have been loose. i will look at it over the weekend. i doubt that any of them have broken or anything, they have only been in there for 8 months. if it was a fuse, which fuse would it be? if it is the led bulb(s), where do i get a new panel? one thing that was odd though, it might now have anything to do with it, but i installed 2 6"-8" speakers on the rear deck about the same time that the light starting going screwy. i did not own the car when it was installed, by the way. thanx for your help!!

-dogg
 
1 - 5 of 5 Posts
Top