Mazda MX-6 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
ok little history here, i wrecked my 1st 89 mx6(non-turbo). Pulled the motor and did all the mods. Went to the junkyard bought a full 89 mx6(nonturbo) for $500.00. Did a motor swap and it cranked up, but the rpm's kept going higher and higher, push the excellerator and it dies. The check engine light stays on too? I switched air flow boxes and ecu's, because I know my old ones were good. Now it don't crank. What the heck is going on?:mad: :confused: :(
 

·
Premium Member
Joined
·
4,973 Posts
If you turn the key and nothing happens but a click (or maybe no click) your starter isn't working. Either it's bad (I've had mine rebuilt) or it's not getting power. If it's not getting power, it would be one of two issues (unless there's something else I'm not aware of.) One, the starter isn't getting power. Two, the neutral switch isn't sending a signal due to being either faulty, not being activated, or not hooked up. Start there first.
 

·
Registered
Joined
·
100 Posts
Is the gound in these starters based on the block itself being grounded? I know that was the problem on my SR20DET on my 240sx... the block had to be grounded in order for the starter to function.... block= connected to tranny starter=connected to tranny.. all must be properly grounded.
 

·
Registered
Joined
·
3,432 Posts
pull the codes

Chances are that it may lead you to the problem. If not, reset the ECU. Next thing to do would be check all of your wiring and connectors. Check the simple stuff first !
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top