Mazda MX-6 Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter · #1 ·
where is this 4ws filter that i am supposed to change on my 4ws every 60000 miles and how much do the filters cost also is there any fluids that i need to change on my 4ws thank you jr
 

·
Registered
Joined
·
9,228 Posts
I dont know but I need to know where it is also. Mine stoped working and Im sure its the filter that needs to be replaced.
 

·
Registered
Joined
·
1,426 Posts
Apparently it's on the front side of the rear rack, towards the top.



I hope you can still get these parts at the dealer. It would be interesting to know if this filter really is the reason so many 4WS cars are broken, and more importantly, if changing it will fix them.
 

·
Registered
Joined
·
9,228 Posts
I dont know if mine is the filter.

I got the 4WS light about 3 months ago and since then it was off and on. I unpluged the 4WS box (under pass. seat) so the light wont stay on.

I pluged it in a little while ago and everytime I turned it would buzz. The rear wheels turned a couple of times, then the light came on and they locked up.

Thanks for the info
 

·
Registered
Joined
·
190 Posts
Discussion Starter · #6 ·
i dont know but my light comes on ever once in awhile .BUT i called on the filter at a mazda dealer ship and they want 75 to 90 dollars for the damn thing i think it comes as a kit with the o ring and rubber gasket .that is way to much for a stupid filter i wonder if i could take it out and clean it .
 

·
Registered
Joined
·
1,426 Posts
$75 for something you do every 60k is not that bad. It's a high-tech system and it's gonna have expensive parts. Bite the bullet and maintain your car right.
 

·
Banned
Joined
·
4,040 Posts
My light comes on in cold weather.
 

·
Banned
Joined
·
4,040 Posts
Do you have the part yet or are you just wanting people to jump through hoops and post pictures while you complain about the price of the part?


You've had 4 months to do something about it. What have you done?
 

·
Banned
Joined
·
4,040 Posts
glad to help

jroreilly84020 said:
would you pls post that pic of where that filter goes again it is not there anymore Thank you



You're welcome.

antiSUV said:
Apparently it's on the front side of the rear rack, towards the top.
Close -- on the back side towards the bottom. The boot showing in the upper left corner of the pic is the left hand (driver's side in NA) tie rod. It's tucked in below the stepper motor (half visible at top of pic).
 
1 - 11 of 11 Posts
Top