Mazda MX-6 Forum banner

1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
Alright this sounds abit weird, but My car runs great, but as soon as the engine warms up, I see a small amount of white smoke venting from under the hood. When I check to see, the smokes eminates from what looks like between the radiator and the engine. I think that it may be oil, maybe radiator fluid. I can seem to locate it, and I will do some real checking tommrow, but if anyone may have a clue as to what it may be or what may be leaking I would greatly appreciate it! Also, and most improtantly, I also smell what seems to be oil inside the car when I use the fresh air vent. And omly after the car warms up. The oil level is actually fairly stabe, but with the constant smell, i get the impression that it's alot of oil is burning! I mean the smell is that bad! I don't get it when I use the recycle button. And it only happens after the car warms up. geesh, it's been buggin, and the smell is killin me. So If anyone can help, PLEASE! Thanx
 

·
Registered
Joined
·
488 Posts
Check the oil pressure sending unit. It is directly above the oil filter adn only sees oil when the car is running. They usually leak around the actual connection for the sender. You can get a new one from teh dealer that has been updated for around $20.
 

·
Registered
Joined
·
475 Posts
I doubt it's oil burning. It sounds more like something burning int he radiator. Because u said it starts after the car warms up, which cause the radiator fan to switch on. Check your coolant levels, and check to see if there is anything like leaves or animals in your radiator that would burn....lol.
 
G

·
Discussion Starter · #5 ·
Actually I just changed the sending unit awhile ago, but I had to loosen the rtadiator to get to it, and maybe that contributed to causing this problem??? And how could something get inside to burn? And where might it burn? Anyways Thanx and I'll check on it!
 
1 - 5 of 5 Posts
Top