Mazda MX-6 Forum banner
1 - 20 of 22 Posts

·
Premium Member
Joined
·
2,048 Posts
Discussion Starter · #1 ·
I have a 93 mx-6 ls atx that has 69k miles on it. it's stupidly slow... I lost to an old civic hatchback that has like 90 something horsepower last night!!! :( What in the world could be wrong with my car that's making it so slow? It runs really well....shifts smooth, the only problem is the rpms jump up and down sometimes when I'm idling. You guys gotta help me, my cars making a mx-6 ls look real real bad :mad:
 

·
Premium Member
Joined
·
3,965 Posts
Well, you can get some klze cams and intake manifold. The VRIS points will be different than a klde but it'll pull nicely. Followed by intake and exhaust, etc.:D
 

·
Premium Member
Joined
·
2,048 Posts
Discussion Starter · #3 ·
I know how to make it faster with stuff like that, but I don't think I should've lost to something with 70 less horsepower than me.... :(
 

·
Premium Member
Joined
·
2,048 Posts
Discussion Starter · #5 ·
Yeah, it's a friend of mines... :rolleyes:
 

·
The Full Dong
Joined
·
2,595 Posts
pull some engine codes...maybe something is outta wack like the TPS. Are you an Auto or 5spd?
 

·
Registered
Joined
·
5,869 Posts
KrisLuvsYou143 said:
I have a 93 mx-6 ls atx that has 69k miles on it. it's stupidly slow... I lost to an old civic hatchback that has like 90 something horsepower last night!!! :( What in the world could be wrong with my car that's making it so slow? It runs really well....shifts smooth, the only problem is the rpms jump up and down sometimes when I'm idling. You guys gotta help me, my cars making a mx-6 ls look real real bad :mad:
With naturally aspirated cars, its pretty hard for a lot of power to disappear without pretty grave symptoms. For instance, if the ignition system is bad enough to cause serious power loss, you'd notice it acting funny at part throttle too, on hills and such.

VRIS can be a silent killer, might wanna try the paper test in addition to pulling the CEL codes.

Big huge exhaust leaks can do it. Course, they are pretty loud :)

Try pulling the codes, takes like 3 minutes. Hopefully it is something simple.

-Garrett
 

·
Registered
Joined
·
2,116 Posts
what rpm do u shift at when racing??

maybe ur brother or somebody modified ur car to go slower so you wouldnt wreck it ;) :p

have u changed ur air filter, fuel filter, spark plugs, wire, rotor and cap, or oil yet?? do u know if ur vris is working? is ur catilitic converter cloged?
 

·
Registered
Joined
·
43 Posts
If your idle is jumping around you may have a vac leak, Check all your hoses and check the elbow by the vaf. Check your trany fluid, and smell the dipstick to see if it smells burnt. I would also pull a few plugs and see if there is oil in there. If you have oil in there then alot of the spark will go into the head instead of the plug. I would also look into changing all the things that aussomea mentioned, There all things you should change anyway. Do you get an egg smell from your exaust? if you do your cat converter is pluged and that would rob you of power. good luck.
 

·
Premium Member
Joined
·
2,048 Posts
Discussion Starter · #10 ·
I tried to pull the codes off of my car and it didn't work? I did the paperclip thing and turned the ignition to on but it never pulled any codes :(
 

·
Registered
Joined
·
5,869 Posts
KrisLuvsYou143 said:
I tried to pull the codes off of my car and it didn't work? I did the paperclip thing and turned the ignition to on but it never pulled any codes :(
Make sure you aren't using one of those paperclips with the plastic coating :) j/k

http://home.golden.net/~trinity/Probe/malf/malfcode.htm

Mike's site is really descriptive..... Just make sure you are grounding the correct pin to the correct pin and all should be good.

Also, you could by some minute chance have a bad CEL. Does the CEL flash on when you start the car?
-Garrett
 

·
Premium Member
Joined
·
2,048 Posts
Discussion Starter · #12 · (Edited)
OOOOhhhhh I was using the wrong ground for it :rolleyes:

I pulled the codes and I got

5-knock sensor
46-VRIS #2 Solenoid
 

·
Registered
Joined
·
2,116 Posts
KrisLuvsYou143 said:
OOOOhhhhh I was using the wrong ground for it :rolleyes:

I pulled the codes and I got

5-knock sensor
46-VRIS #2 Solenoid
those would slow u down :rolleyes:
 

·
Registered
Joined
·
2,658 Posts
Mike's site is really descriptive..... Just make sure you are grounding the correct pin to the correct pin and all should be good.
So when that diagram on the site is "brown" that doesnt mean anything? just the orange flashes...right?
 

·
Registered
Joined
·
5,869 Posts
ckozlgod said:
So when that diagram on the site is "brown" that doesnt mean anything? just the orange flashes...right? [/QUOTE

Word.]
 

·
Registered
Joined
·
5,869 Posts
KrisLuvsYou143 said:
OOOOhhhhh I was using the wrong ground for it :rolleyes:

I pulled the codes and I got

5-knock sensor
46-VRIS #2 Solenoid
The VRIS 2 will definitely slow you down. I'd bet the Knock Sensor code is prolly equally at fault .

Dunno in particular about the Mazda PCM, but most PCM's default to a really retarded ignition setting compared to optimal when a knock sensor is faulted.

So in otherwords, your motor is prolly running a known safe timing map that would work with 86 or 87 octane gas....big power loss.

Getting to the knock sensor is rather difficult if you haven't done it before, but its a fairly easy/cheap item to replace.
-Garrett
 

·
Registered
Joined
·
2,064 Posts
You should try resetting your PCM, basically making it forget that the two codes are stored, and see if that makes your car any quicker. You can reset your PCM by disconnecting the battery for about 5 minutes then reconnecting and letting the car idle for a few.
 

·
Registered
Joined
·
52 Posts
Check your cat is ok

I had similar problems, way down on power but the car felt ok.

start the car and put your hand over the exhaust, it is a constant blowing rather than a pulsing it could be you cat is blocked.

mine lost me about 80hp, but the car ran ok.

worth a try.
 

·
Registered
Joined
·
2,658 Posts
i too just pulled codes and i got
15,17-o2 sensors-maybe cause i have no cat?
46-vris solenoid 2, just like you kris


so basically how do i take car of this?
 
1 - 20 of 22 Posts
Top