Mazda MX-6 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Can someone help please. I am putting a 93 Ford Probe 4 cyl w/standard trans into a 93 MX6 that had auto trans and I am having wiring issues. The wiring is close, but not quite the same. Has anyone done this swap before that could help me identify the crucial engine electrical connections? I swapped the computer from the Probe, as well as the main wiring harness. I am particularly having problems getting power to the starter, fuel pump and injectors. The motor runs on starter fluid with a little bypassing, but the essential systems are not getting power apparently. Can anyone help or hook me up with a link that may have some information? I would greatly appreciate it.
 

·
Its not butter?!!!!1
Joined
·
4,968 Posts
you need the correct ECU.. honestly man.. my car used to be an auto.. now its a manual.. and the car has never once run 100%.. its always idled at 1200 rpm (most of the time) its always been hard to start when its cold.. just find another engine.. one with a pre-existing 5 speed already.. it'll save yourself enormous amounts of work.

(about $3k worth what I just finished spending getting the wiring harness professionally re-furbished)
 

·
Registered
Joined
·
1,291 Posts
no u can keep ur auto ecu with a mtx car, and he already said he had the ecu from the ford...have u checked fuses and grounding points? if it starts than ur injectors are getting signal from ecu and they are opening to fire, theres only one connection to ur starter so that shouldnt be a problem, i would make sure ur parts are in working order as well as the fuses/relays for them
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Sorry. To clarify my post, the MX6 used to have a 6cyl motor with auto trans and I am putting a Ford Probe 4cyl with standard trans in its place. I have BOTH cars available with both sets of harnesses, computer, etc. Some of the connectors are different and I was trying to avoid a point-to-point wiring trace if someone had done this swap before and knew which connectors were the critical difference in the swap. The tracing is difficult because the book I am using does not reference the specific location and pinout of the connectors (and there are a BUNCH of them on this car...especially being an LS.) I have swapped out the braking system to eliminate the anti-lock braking system (used the entire front end assembly from the Probe), but everything else is pretty much the way it was originally. I switched the main wiring harness and computer to the ones from the Probe. It was amazing how well everything fit together. There was even a blank-off plate for the clutch out of the probe and everything just bolted right up, but now I'm down to wiring issues. I am considering subscribing to the AllData DIY online service manual thing since they show all of the connectors for both cars, but I am unable to find anyone to vouch for the accuracy of their data on these specific cars. I have a call in to the Mazda dealer here in town about a factory service manual, but I don't know how comprehensive these are either. Heck, for that matter, I don't even know if the manual I am using is accurate....just taking it on faith I guess. If anyone has any thoughts, I would appreciate the input/help. Thanks.

P.S. I am planning to find another engine (original V6 type) and rebuild it for performance (considering the turbo mod) over the next two years (spacing the time due to the cost), but I would love to be able to run it with what I have on hand for now.
 
1 - 5 of 5 Posts
Top