Mazda MX-6 Forum banner

1 - 8 of 8 Posts
T

·
Guest
Joined
·
0 Posts
Discussion Starter #1
MX6 won't idle

After reading all the posts on this topic, I realize I am not the only person who has been through the following...

MY 1993 MAZDA MX6 4 CYL WILL NOT IDLE. Cold, warm or hot.

My car starts fine and runs fine as long as my foot is on the accelerator. As soon as I remove my foot and try to slow down or idle, the car dies. Side note... I seem to be noticing worsening gas mileage.

I have this problem occassionally. It comes on suddenly and seems to last for a few days and then go away. In the past I have changed plugs, wires, fuel filters, air filters, distributor caps and rotor buttons and unfortunately I cannot remember which of these, if any, worked. All I remember is that eventually the problem goes away.

Plugs and wires look fine, I think. Replaced plugs about 10k miles ago. Replaced distributor cap and button about same time.

Used throttle body cleaner and cleaned throttle body. It looked and looks clean.

I'm tired of driving with two feet!!!!!
 

·
Registered
Joined
·
257 Posts
yeah, check vacuum lines arond the areas you performed work. ESPECIALLY near the air filter. that big one near the t/b elbow was the culprit for me. another time it was the wire harness going into the VAF sensor. same symptoms tho.

good luck!
L8R
Nick
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Good call blu....thats where mine was.....went to tha auto store....bought an elbow for $2.50 and it fixed the problems
 

·
Registered
Joined
·
22 Posts
I recently had this problem, when i start my car the car idles low then car starts to jerk then soon dies and have to start the car agian but car is fine if you press on gas and keep it idleing high. everytime i stoped at a stoplight i had to put it in neutral and step on gas for it not to die. But I recently fixed the problem and my car is great, My car has a 140,000 miles on it i replaced the timing belt, valve cover gasket, fuel pump, fuel filter, intake mainifold gasket, and oil pressure switch, and oil pan gasket. It cost about 900$ all together. I recommend going to the dealer and let them find what the problem is and then you go from there, but they will charge you about 45$ fee for finding the problem, but its better to take it to the dealer and having the problem fixed right.
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #6
ITS FIXED!!!!

Took my car to the dealer.

Carbon build up in the throttle chamber and bac valve. Car runs great and costs about $125 to fix including new gaskets and air filter.

YEA!
 

·
Registered
Joined
·
100 Posts
Ok, what you guys explained sounds exactly what i'm going through. I just want to know if your any of you engine lights went on? Th problem seems to have gone away for now. I'm planning to replace the distributor cap and rotor, the wires, the fuel filter, and I'm going to put on a K&N filter setup that replaces the stock air box. I'm going to do the diagnostic check and see what the computer on the car gives me. Also, I put a bottle of fuel system cleaner in the car, and that seemed to have helped some.
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #8
Tried that.

Joe_silver93 said:
Ok, what you guys explained sounds exactly what i'm going through. I just want to know if your any of you engine lights went on? Th problem seems to have gone away for now. I'm planning to replace the distributor cap and rotor, the wires, the fuel filter, and I'm going to put on a K&N filter setup that replaces the stock air box. I'm going to do the diagnostic check and see what the computer on the car gives me. Also, I put a bottle of fuel system cleaner in the car, and that seemed to have helped some.
JOE,

My problem also started out and went away. Happened a few times over a few YEARS. I also did what you are getting ready to do (replacing everything) and it did seem to help. However, (see my previous note about fixing the problem) I believe that these fixes are only fixing symptoms of the real problem of carbon build up in the bac valve and throttle chamber. I tried to fix the problem myself but was unsuccessful. I was VERY HAPPY with the performance of my dealer. My car now runs great! Perfect idle at about 800 rpm and it adjusts perfectly when the a/c or other load comes on.

Best of luck. I messed with my problem for years!

Let me know if I can help further.

Trey
 
1 - 8 of 8 Posts
Top